Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21812 - [mesa] libgl 7.9 segfault when using swrast

Attached to Project: Arch Linux
Opened by Thomas Courbon (thcourbon) - Wednesday, 24 November 2010, 09:40 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 13 February 2011, 19:56 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I upgraded my mesa packages to testing whit the hope it would enable support for my hd5770.
When rebooting:
* The boot process goes until login
* As I use autologin, the KDE desktop start to load
* In the middle of loading, the screen flicker a little and the kdm screen is displayed
* If I try to log in, the desktop start to load again, the screen flicker, and the kdm screen is displayed again.

I reported a bug on the official fd.o bug tracker with detail and a bisected commit. It hasn't received much attention and despite my attempts I wasn't able to run the desktop loading into a debugger. If you have any hint on that I can try to provide further informations.

I know that this is an upstream bug, but I red on the arch-dev-public that mesa 7.9 is expected to land on extra soon. So it's more an informative report that an request.

Additional info:
* package version(s) : all mesa package to 7.9, but the segfault happen as soon as you install libgl 7.9 (ie all mesa at 7.9 but libgl at 7.8.x = no segfault)
* config and/or log files etc. : My graphic gard doesn't seem to be supported in mesa 7.9, so it use swrast.
* fd.o bug repport : https://bugs.freedesktop.org/show_bug.cgi?id=31579


Steps to reproduce:
Use a hd 5770, install mesa 7.9, reboot.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 13 February 2011, 19:56 GMT
Reason for closing:  Fixed
Comment by Andrew D. (andrewd18) - Monday, 29 November 2010, 02:51 GMT
I also have this same issue. I'm currently working around it by using the KDE Failsafe login instead of the regular KDE session.
Comment by Andreas Radke (AndyRTR) - Monday, 29 November 2010, 06:49 GMT
I recently had a HD5450 card and it went fine with mesa7.9 but required xf86-video-ati-git from AUR. You may want to try it out.
Comment by Thomas Courbon (thcourbon) - Monday, 29 November 2010, 15:04 GMT
I worked around this by swithcing to mesa-git and xf86-ati-git. As it's "only" a segfault I hoped (so foolish of me) I can propose a patch to fix that. But I can't even get a useful backtrace since it crash during Desktop loading, something kdm launch by (I guess) forking. So event If I do something like "gdb kdm", I can't get anything.
Comment by Andreas Radke (AndyRTR) - Monday, 29 November 2010, 15:36 GMT
you can try to git bisect the error or look out for related fixes in the mesa 7.9 stable branch.
Comment by Thomas Courbon (thcourbon) - Monday, 29 November 2010, 15:50 GMT
The faulty commit was bisected (see fd.o bug report : https://bugs.freedesktop.org/show_bug.cgi?id=31579 ) and I tested mesa-git (without xf86-video-ati-git to force my computer to use swrast): the segfault still happen. I believe that swrast doesn't receive to much attention these days since it will be soon deprecated in favour of Gallium3D soft renderer (dunno if it's softpipe or llvmpipe).

Also I tried to get some help from the #mesa IRC channel, but no one was able to help me get a stacktrace (maybe I'm dumb ;) .
Comment by Andreas Radke (AndyRTR) - Saturday, 18 December 2010, 11:15 GMT
please test mesa 7.10 in testing.
Comment by Andrew D. (andrewd18) - Friday, 07 January 2011, 17:03 GMT
Sorry for the late response; holidays got the best of me. :) I will test it this weekend.
Comment by Andrew D. (andrewd18) - Thursday, 20 January 2011, 00:29 GMT
Using xf86-video-ati-git-20101129-1 and mesa-7.9.99.git20101217-1 does not cause the segfault.
Using xf86-video-ati-6.13.2-2 and mesa-7.10-1 still causes a segfault unless I load KDE failsafe mode.
Using xf86-video-ati-git-20110119-1 and mesa-7.10-1 does not cause the segfault.
Comment by Andreas Radke (AndyRTR) - Saturday, 12 February 2011, 23:26 GMT
how's state with xf86-video-ati 6.14?
Comment by Andrew D. (andrewd18) - Sunday, 13 February 2011, 19:51 GMT
Using xf86-video-ati 6.14 resolves the crash for me with both Mesa 7.9.99.git20101217-1 and Mesa 7.10.

Loading...