Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21784 - [makepkg] PACKAGER envvar doesn't work

Attached to Project: Arch Linux
Opened by Filipp Andjelo (scorp) - Monday, 22 November 2010, 11:09 GMT
Last edited by Ionut Biru (wonder) - Monday, 22 November 2010, 11:43 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
If using makepkg, then PACKAGER variable can be only set in /etc/makepkg.conf
Since there are many users on the system, I can't use global setting and have
to use per user defined PACKAGER environment variable, which is silently ignored
by makepkg now.

Additional info:
* package version(s)
pacman-3.4.1

Steps to reproduce:
1) export PACKAGER="Hello World"
2) run makepkg
3) look into PKGINFO file for packager entry


This task depends upon

Closed by  Ionut Biru (wonder)
Monday, 22 November 2010, 11:43 GMT
Reason for closing:  Not a bug
Additional comments about closing:  documentation fixed
Comment by Ionut Biru (wonder) - Monday, 22 November 2010, 11:14 GMT
add in ~/.makepkg.conf PACKAGER="whatever"
Comment by Filipp Andjelo (scorp) - Monday, 22 November 2010, 11:33 GMT
Tnak you! That works fine, somebody should fix the dokumentation in Wiki under https://wiki.archlinux.org/index.php/Arch_Packaging_Standards#Package_Etiquette
I have no Wiki ArchLinux account (off topic: would be nice to finaly have one login/password for all stuff on ArchLinux, Wiki, Forum, AUR s.o)

Loading...