Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#21682 - [gthumb] still can't import photos after installing optdepend exiv2

Attached to Project: Arch Linux
Opened by fauno (fauno) - Saturday, 13 November 2010, 03:17 GMT
Last edited by Allan McRae (Allan) - Friday, 16 November 2012, 11:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Description: Today I wanted to import photos from my camera and the photo importer extension couldn't be loaded because of missing libexiv2. The problem was solved when I installed exiv2 package, but gthumb doesn't show anything on the importer window, not even the camera. A few times it segphaulted, but I can't reproduce this. Camera's recognized correctly by gphoto2 and --get-all-files downloaded everything OK.

Additional info:
* gphoto2 2.4.10-1
* gthumb 2.12.0-2
* Canon PowerShot G10 (camera)

Steps to reproduce:
* Connect camera
* Wait until kernel loads the module
* Run gthumb -i or,
* Run gthumb and then go to File > Import from > Device (I'm retranslating from spanish)
This task depends upon

Closed by  Allan McRae (Allan)
Friday, 16 November 2012, 11:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  Seems fixed... ish.
Comment by Ionut Biru (wonder) - Saturday, 13 November 2010, 14:50 GMT
i'm fixing the dependency problem but for your actually problem, you have to report it upstream.

gthumb 2.12.0 was totally rewrote and some things are missing
Comment by Ionut Biru (wonder) - Monday, 22 November 2010, 18:10 GMT
is this still valid using gphoto2 2.4.11 gthumb 2.12.1?
Comment by Peter Hardman (shetland_breeder) - Monday, 06 December 2010, 10:36 GMT
Yes. I don't get the segfault but the import dialog is still greyed out.

Comment by Ionut Biru (wonder) - Monday, 06 December 2010, 10:50 GMT
i don't own a camera to test them and i don't have any clue what is wrong.

lets start by installing this package:
Comment by Peter Hardman (shetland_breeder) - Monday, 06 December 2010, 17:00 GMT
I've been playing about...

The media-player-info package is irrelevant - it has no udev rules applicable to cameras. The camera appears in the udev database whether there are rules or not - I guess the kernel recognises it?

In any case, gThumb 2.10.12-1 doesn't need any udev rules to read from the camera. BTW both JGC and my cameras are PTP so don't need to be (can't be) mounted.

libgphoto2 has a set of udev rules in /lib/udev/rules.d/40-gphoto.rules but these just set some environment variables. It makes no difference to gThumb if these rules are disabled or not.

The fact that the whole import dialog is disabled apart from the Cancel and Help buttons seems to me to indicate that either something really fundamental is missing or that it's not supposed to be working yet.

Comment by Peter Hardman (shetland_breeder) - Thursday, 31 March 2011, 12:55 GMT
This problem still exists in 2.12.2, at least on XFCE4 4.8.

I posted a query about this on the gThumb list, but basically no-one had any ideas, although it does appear that it works for most people. I guess it's dependant on something that gets installed by default with Gnome as both the gphoto CLI and Gtkam can import photos, and the import dialog will recognise a USB stick.

Comment by siriusb (siriusb) - Tuesday, 19 July 2011, 13:36 GMT
gThumb 2.13.2
Arch Linux 2.6.39 x86_64
Canon PowerShot S2 IS

Can't import photos, error message: Couldn't load folder, Permission denied.
Seems for me device isn't recognized.

Installed gvfs-gphoto2, same outcome.

In terminal:
$ gthumb -i
/home/siriusb/.gtkrc-2.0:7: Unable to locate image file in pixmap_path: "stock_mail-unread-multiple.png"
/home/siriusb/.gtkrc-2.0:11: Unable to locate image file in pixmap_path: "mail-mark-read.png"

(gthumb:10904): GLib-GObject-CRITICAL **: g_object_ref: assertion `G_IS_OBJECT (object)' failed

(gthumb:10904): GLib-GIO-CRITICAL **: g_file_new_for_path: assertion `path != NULL' failed

(gthumb:10904): Gtk-CRITICAL **: IA__gtk_file_chooser_set_current_folder_file: assertion `G_IS_FILE (file)' failed

(gthumb:10904): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(gthumb:10904): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

Bug report:

PS: digikam works
Comment by Allan McRae (Allan) - Saturday, 02 June 2012, 12:25 GMT
Comment by siriusb (siriusb) - Monday, 11 June 2012, 19:55 GMT
Sorry for the late response.

After manually mounting the camera gThumb can import the photos.

Anyway, I use this script below with Thunar volman to work around the issue since this problem occured.
CAMPORT=`gphoto2 --auto-detect | grep 'S2 IS' | cut -c 38- | sed 's/ //g'`
gvfs-mount "gphoto2://[usb:$CAMPORT]/"
gvfs-mount --unmount-scheme gphoto2

gthumb 3.0.1-1
Comment by Greg (dolby) - Tuesday, 16 October 2012, 05:50 GMT
This is no longer valid then? Above gnome bug report is still open but reporter says it works.