Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21664 - [xdg-utils] xdg-mime fails to set chromium as default browser

Attached to Project: Arch Linux
Opened by Federico Chiacchiaretta (baghera) - Wednesday, 10 November 2010, 20:45 GMT
Last edited by Eric Belanger (Snowman) - Sunday, 19 June 2011, 04:08 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
Hi all,
I can't set chromium as my default browser from the settings window because of a bug in xdg-mime script (included in xdg-utils). As stated in [1] and [2] the bug has been fixed by chromium devs shipping an updated version of xdg-mime with the browser, but arch package use xdg-mime shipped with xdg-utils from [extra], so the fix doesn't work here.
I just grabbed an updated version of xdg-mime script from [3] and put it in /usr/bin , and I can confirm this new version works properly. Would it be possible to have an updated xdg-utils pkg in [extra]? As far as I can see, the package in [extra] is a development version yet.

Additional info:
* 1.0.2.20100618-1

[1] http://src.chromium.org/viewvc/chrome?view=rev&revision=58449
[2] http://code.google.com/p/chromium/issues/detail?id=33842
[3] http://webcvs.freedesktop.org/portland/portland/xdg-utils/scripts/xdg-mime?view=co
This task depends upon

Closed by  Eric Belanger (Snowman)
Sunday, 19 June 2011, 04:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in xdg-utils 1.1.0rc1

Loading...