Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21649 - [dhclient] Package should contain /var/lib/dhclient directory

Attached to Project: Arch Linux
Opened by Jan Steffens (heftig) - Tuesday, 09 November 2010, 07:34 GMT
Last edited by Andrea Scarpino (BaSh) - Tuesday, 16 October 2012, 07:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Kevin Piche (kpiche)
Isenmann Daniel (ise)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Otherwise you're seeing errors like this:

dhclient: can't create /var/lib/dhclient/dhclient-bf48d941-dc1f-44f8-9300-da49462ec749-wlan0.lease: No such file or directory

dhclient 4.2.0-1
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Tuesday, 16 October 2012, 07:34 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#28032 
Comment by Jan Steffens (heftig) - Thursday, 11 November 2010, 02:26 GMT
Should be fixed in trunk. Geez, $startdir.
Comment by Mariusz Libera (mar04) - Saturday, 21 January 2012, 18:23 GMT
  • Field changed: Percent Complete (100% → 0%)
The directory is not there, and errors are back.
Comment by Isenmann Daniel (ise) - Thursday, 02 February 2012, 07:34 GMT
/var/state/dhclient/ is included into the package. Have a look at the file list of the package details: https://www.archlinux.org/packages/extra/i686/dhclient/
And in the PKGBUILD the /var/state/dhclient/ directory is given as the lease file directory.
Comment by Mariusz Libera (mar04) - Thursday, 02 February 2012, 09:19 GMT
So should I ignore:

Feb 2 10:10:13 localhost dhclient: can't create /var/lib/dhclient/dhclient-7fcd578b-0665-4cc2-8627-061b26cc4118-wlan0.lease: No such file or directory

messages in my /var/log/errors.log?
Comment by Allan McRae (Allan) - Saturday, 28 April 2012, 11:59 GMT
Is there /var/state vs /var/lib confusion going on here?
Comment by Greg (dolby) - Monday, 15 October 2012, 03:54 GMT
Is this still a problem?
Comment by Mariusz Libera (mar04) - Monday, 15 October 2012, 09:22 GMT
For some reasons I'm no longer using Arch, so can't tell.
Comment by Greg (dolby) - Tuesday, 16 October 2012, 07:00 GMT
This is a duplicate of  FS#28032 

Loading...