Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21610 - {wiki} DB error when edit discussion page with russian letters in title

Attached to Project: Arch Linux
Opened by Ivan (IIIcyg) - Friday, 05 November 2010, 07:21 GMT
Last edited by Pierre Schmitz (Pierre) - Sunday, 06 May 2012, 15:09 GMT
Task Type Bug Report
Category Web Sites
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

When I try to click «edit» or «+» on this page (or any other page with russian letters in title):
https://wiki.archlinux.org/index.php/Talk:Internationalisation_%28%D0%A0%D1%83%D1%81%D1%81%D0%BA%D0%B8%D0%B9%29
— archwiki reports:

Database error
A database error has occurred
Query: SELECT lc_value FROM `l10n_cache` WHERE lc_lang = 'en' AND lc_key = 'messages:editnotice-1-Internationalisation_(Русский)' LIMIT 1
Function: LCStore_DB::get
Error: 1267 Illegal mix of collations (latin1_general_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation '=' (localhost)

Steps to reproduce:
1. Open https://wiki.archlinux.org/index.php/Internationalisation_%28%D0%A0%D1%83%D1%81%D1%81%D0%BA%D0%B8%D0%B9%29 — or any another page with russian letters in title;
2. Click «discussion» (to go on the page: https://wiki.archlinux.org/index.php/Talk:Internationalisation_%28%D0%A0%D1%83%D1%81%D1%81%D0%BA%D0%B8%D0%B9%29);
3. Click «edit» or «+».
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Sunday, 06 May 2012, 15:09 GMT
Reason for closing:  Fixed
Comment by Linas (Linas) - Sunday, 07 November 2010, 23:25 GMT
May be due to having $wgDBmysql5 = true in LocalSettings
Comment by Desmond Cox (pointone) - Sunday, 14 November 2010, 04:29 GMT
I only experience this problem with the Internationalisation page you link to -- every other Russian page works fine for me.

*Edit:* Never mind; missed the _discussion_ part. Confirmed.
Comment by Pierre Schmitz (Pierre) - Sunday, 14 November 2010, 05:54 GMT
I actually know the problem, but didn't have time to fix it yet. The mediawiki update script simply missed to update some table definitions. In this case the encoding/collation is wrong.
Comment by Dario Giovannetti (kynikos) - Tuesday, 12 July 2011, 09:01 GMT
Any progress with this bug? By the way I'm remarking that the error happens with non-Latin letters in general, and also with extended Latin alphabets (e.g. Czech).
Comment by Pierre Schmitz (Pierre) - Saturday, 23 July 2011, 18:50 GMT
Fixing this would be a lot of work, including testing and some downtime. It's also not a high priority for me as the wiki pages are supposed to be in English anyway.
Comment by chaofeng (rainofchaos) - Saturday, 05 May 2012, 03:02 GMT
"wiki pages supposed to be in English" is not true. There are over 300 Simplified Chinese pages now, though not all of them are well translated.

Now this bug affect not only i18n talk pages but also all i18n pages. If not fixed, it may make ArchWiki English only.

If this bug will not be fixed soon. Then I have to propose to change the i18n naming rule. Maybe from "Table of Contents (简体中文)" to "Table of Contents (zh_CN)"

Loading...