Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21606 - [kernel26] PIONEER DVD-RW DVR-212D: failed to set xfermode

Attached to Project: Arch Linux
Opened by Pat (whaevr) - Friday, 05 November 2010, 01:13 GMT
Last edited by Tobias Powalowski (tpowa) - Tuesday, 14 February 2012, 14:33 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Reported problem is the exact same as:
http://thread.gmane.org/gmane.linux.ide/36790

And there was a submitted patch that fixed the problem but it was limited to PIONEER DVD-RW DVRTD08

This same issue has popped up again log here
https://bbs.archlinux.org/viewtopic.php?id=107847

So I made a simple patch to add this drive to the list that benefits from the patch mentioned in the first link, this solved the problem.

Additional info:
* package version(s)
* config and/or log files etc.

Steps to reproduce:
Boot archlinux with the 2.6.36 kernel from testing
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Tuesday, 14 February 2012, 14:33 GMT
Reason for closing:  Fixed
Comment by Francesco Antonacci (punkeroso) - Friday, 26 November 2010, 08:01 GMT
New kernel in testing, same problem; my dvd burner is not recognized anymore. I need to rebuild the kernel appling the attached patch.
Comment by Tobias Powalowski (tpowa) - Friday, 26 November 2010, 13:58 GMT
You need to send this to upstream dev to get it into the mainline.
Comment by Thomas Bächler (brain0) - Friday, 26 November 2010, 14:33 GMT
While this is true, we can still apply this patch in the next version, it seems rather harmless. Submitting it upstream is very important though, as we cannot maintain our own kernel patches long-term.
Comment by Pat (whaevr) - Sunday, 28 November 2010, 22:04 GMT
Well I wouldn't know how to go about submitting it upstream..if its not that big of a deal could one of you submit it??
Comment by Erus (Erus_Iluvatar) - Thursday, 03 February 2011, 16:49 GMT
Here is a patch that includes my PIONEER DVD-RW DVRTD08A 1.50

Anyone to get this to upstream?
Comment by Joan Coll Cerdán (johanbcn) - Monday, 07 March 2011, 15:54 GMT
It happens too with my "PIONEER DVD-RW DVR-216D, 1.07, max UDMA/66".
I guess it's a problem with all Pioneer DVR-2x sata drives?
Comment by Jelle van der Waa (jelly) - Thursday, 16 June 2011, 10:21 GMT
still an issue with .39? If so please report upstream
Comment by Owain Sutton (owain) - Sunday, 28 August 2011, 11:26 GMT
Bug still exists in kernel26 2.6.39.3-1 It's months since I last used my CD drive, so presumably has been there in past updates, too.

This is with dmesg reporting:

ata2.00: ATAPI: PIONEER DVD-RW DVRTD08RS, 1.05, max UDMA/33

Modifying the patch to the following resolves the problem:

{ "PIONEER DVD-RW DVRTD08", "1.05", ATA_HORKAGE_NOSETXFER },

I know nothing much about patching or reporting upstream, so would be grateful for help! Thanks
Comment by Tom Gundersen (tomegun) - Sunday, 28 August 2011, 11:54 GMT
I just looked through the git log, and most of these problems should be fixed in 3.0.

@Erus_Iluvatar: I'm not sure if your problem has been fixed. The quirk applies to PIONEER DVD-RW DVRTD08, but I'm not sure if it will also apply to PIONEER DVD-RW DVRTD08A (with the "A" at the end). If you still have a problem please email <linux-ide@vger.kernel.org> and let them know that the "ATA_HORKAGE_NOSETXFER" quirk must be applied to "PIONEER DVD-RW DVRTD08A" (they no longer care about the firmware versions).

@tpowa,brain0: I guess this bug can be closed again, I just wanted to let everyone know the current status.
Comment by Erus (Erus_Iluvatar) - Sunday, 28 August 2011, 14:16 GMT
I still experience this problem with 3.0.3, and will report to mailing list asap.
Comment by Mathias Anselmann (matse) - Sunday, 13 November 2011, 10:04 GMT
I have this problem, too with kernel 3.1.1 and a "PIONEER DVD-RW DVR-215, 1.22"...
Comment by Tom Gundersen (tomegun) - Sunday, 13 November 2011, 11:03 GMT
@matse: this is the relevant quirks list: <http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=blob;f=drivers/ata/libata-core.c;h=c04ad68cb602f20f734b25130e5dfbc7ac72bfd2;hb=HEAD#l4126>.

If your drive needs to be added you should email linux-ide@vger.kernel.org .
Comment by Erus (Erus_Iluvatar) - Sunday, 08 January 2012, 12:27 GMT
@matse I send today a patch with your drive and mine :)
Comment by Tom Gundersen (tomegun) - Sunday, 08 January 2012, 13:00 GMT
@Erus: the patch looks good.
Comment by Mathias Anselmann (matse) - Sunday, 08 January 2012, 17:16 GMT
@Erus: Great! Thank you very much.

Loading...