Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21568 - /etc/arch-release should contain version information

Attached to Project: Arch Linux
Opened by Richard Jones (rwmjones) - Tuesday, 02 November 2010, 10:59 GMT
Last edited by Allan McRae (Allan) - Tuesday, 02 November 2010, 11:09 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

/etc/arch-release is empty. Just about every other Linux
puts a simple string in their equivalent *-release file
which contains the name and version of the product.

We require this in our program "virt-inspector" which reads
a Linux disk image to determine the distro and version.

Steps to reproduce:

$ cat /etc/arch-release
[no output]

Should have a single line saying something like
Arch Linux 2010.05

Compare Arch Linux guest:

$ sudo guestfish -i -a /dev/vg_trick/Arch201005x64

Welcome to guestfish, the libguestfs filesystem interactive shell for
editing virtual machine filesystems.

Type: 'help' for a list of commands
'man' to read the manual
'quit' to quit the shell

/dev/vda3 mounted on /
/dev/vda1 mounted on /boot
/dev/vda4 mounted on /home

to another Linux guest:

$ sudo ./fish/guestfish -i -a /dev/vg_pin/MeeGo11x32

Welcome to guestfish, the libguestfs filesystem interactive shell for
editing virtual machine filesystems.

Type: 'help' for a list of commands
'man' to read the manual
'quit' to quit the shell

Operating system: MeeGo release 1.1 (MeeGo)
/dev/vda2 mounted on /
/dev/vda1 mounted on /boot

Notice the other Linux guest has OS name and version
detected automatically. Not possible for Arch Linux
because you don't make this information available.
This task depends upon

Closed by  Allan McRae (Allan)
Tuesday, 02 November 2010, 11:09 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#10393   FS#7163   FS#7493  ....
Comment by Allan McRae (Allan) - Tuesday, 02 November 2010, 11:07 GMT
So we should update the package daily? Arch has no release version, just an installer date which is useless one you update.

Loading...