Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21528 - [portmidi] libporttime.so: cannot open shared object file: No such file or directory

Attached to Project: Community Packages
Opened by callea gaetano andrea (cga) - Friday, 29 October 2010, 22:03 GMT
Last edited by Lukas Fleischer (lfleischer) - Saturday, 30 October 2010, 18:31 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Lukas Fleischer (lfleischer)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

launching mixxx from a terminal gives the following error: (it won't start from menu...)

cga@gwenllian:~$ mixxx
mixxx: error while loading shared libraries: libporttime.so: cannot open shared object file: No such file or directory

I don't know if it's either about a wrong portmidi or mixxx compilation, would be nice to straight this up. Meanwhile I provide my workaround for this at the end of bug report.

Additional info:
* package version: 1.8.1-1

Steps to reproduce:

Install mixxx and all its dependecies as of package version 1.8.1-1,
launch it via terminal with command "mixxx".

Workaround:

root@gwenllian:~# ln -s /usr/lib/libportmidi.so /usr/lib/libporttime.so
root@gwenllian:~# ldconfig

This could temporarily be put in mixxx.install post install () {} too.

Thank you for making arch such a great distro.

--
cga
knowledge has no owner, only means to reveal itself.
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Saturday, 30 October 2010, 18:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 217-2.
Comment by Lukas Fleischer (lfleischer) - Saturday, 30 October 2010, 14:19 GMT
Strange, works here. `ldd /usr/bin/mixxx | fgrep libporttime.so` also outputs nothing and if I grep all files of the mixxx and porttime packages for "porttime", I only get some lines from include files. Are you on i686 or x86_64?
Comment by callea gaetano andrea (cga) - Saturday, 30 October 2010, 14:24 GMT
Hi Lukas,

I'm on x86_64 and without that trick it didn't work.

I've also installed LenMus from AUR since it required libporttime.so and it didn't compile saying that it was not installed until that trick.
Comment by Lukas Fleischer (lfleischer) - Saturday, 30 October 2010, 15:49 GMT
cga: Should be fixed in 217-2. Could you please update and test again?
Comment by callea gaetano andrea (cga) - Saturday, 30 October 2010, 17:25 GMT
Ok, I'll test as soon as mirrors have it.
Comment by callea gaetano andrea (cga) - Saturday, 30 October 2010, 18:25 GMT
ok fixed.

now portmidi links libporttime too:

portmidi-217-2-x86_64 50.3K 279.4K/s 00:00:00 [################################################################] 100%
checking package integrity...
(1/1) checking for file conflicts [################################################################] 100%
(1/1) upgrading portmidi [################################################################] 100%
root@gwenllian:~# ll /usr/lib/libportmidi.so
-rwxr-xr-x 1 root root 36384 Oct 30 17:38 /usr/lib/libportmidi.so
root@gwenllian:~# ll /usr/lib/libporttime.so
lrwxrwxrwx 1 root root 23 Oct 30 17:38 /usr/lib/libporttime.so -> /usr/lib/libportmidi.so

thanks Lukas =)

Loading...