Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#21507 - pacman needs protection against a full root partition.

Attached to Project: Pacman
Opened by trusktr (trusktr) - Thursday, 28 October 2010, 02:29 GMT
Last edited by Dan McGee (toofishes) - Thursday, 28 October 2010, 02:33 GMT
Task Type Feature Request
Category Backend/Core
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version 3.4.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

So pacman (or me?) completely destroyed my system because the root partition was completely full, a complete disaster.

Pacman should be able to detect these circumstances and abort immediately with a special message to notify you, NOT obliterate your system.

Also, i didn't read about this type of a situation anywhere on archlinux.org. A section entitled "Necessary Precautions" would be nice to have in the Pacman page of the wiki containing explanations of what to do in these scenerios. I had no idea this would happen and I won't be the last...
This task depends upon

Closed by  Dan McGee (toofishes)
Thursday, 28 October 2010, 02:33 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Don't file duplicate bugs.  FS#21481 ,  FS#11639 
Comment by Dan McGee (toofishes) - Thursday, 28 October 2010, 02:32 GMT
Why are you wasting our time on this again? The other bug report you filed ( FS#21481 ) was already closed as a dupe of  FS#11639 .

Guess what? You can edit the wiki as well.
Comment by Allan McRae (Allan) - Thursday, 28 October 2010, 03:23 GMT
The wiki page for pacman is actually locked but you can add stuff to its discussion page.

Loading...