Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#21481 - pacman spewing out errors EVERYWHERE! Possibly SEVERE.

Attached to Project: Pacman
Opened by trusktr (trusktr) - Tuesday, 26 October 2010, 19:18 GMT
Last edited by Ionut Biru (wonder) - Tuesday, 26 October 2010, 19:41 GMT
Task Type Bug Report
Category Backend/Core
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version 3.4.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Today I tried to do pacman -Syu

a fourth of the way into the installs, error began spewing all over the place that look like this:


Error syncing configuration data: Failed to write some configuration data to disk
error: command failed to execute correctly
(148/324) upgrading gedit [######################] 100%

(gconftool-2:10150): GConf-WARNING **: Failed to write "/etc/gconf/gconf.xml.defaults/%gconf-tree.xml": Error writing file "/etc/gconf/gconf.xml.defaults/%gconf-tree.xml.new": No space left on device

Error syncing configuration data: Failed to write some configuration data to disk
(149/324) upgrading vte [######################] 100%
error: could not create temp directory
(150/324) upgrading gucharmap [######################] 100%
error: could not create temp directory
error: could not create temp directory
(151/324) upgrading gedit-plugins [######################] 100%
error: could not create temp directory
error: could not create temp directory
^C52/324) upgrading gimp [###############-------] 71%
Interrupt signal received
(152/324) upgrading gimp [######################] 100%
gtk-update-icon-cache: **
Gtk:ERROR:updateiconcache.c:1102:write_bucket: assertion failed: (*offset == ftell (cache))
/tmp/alpm_z9MBQe/.INSTALL: line 1: 10156 Aborted gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
error: command failed to execute correctly


So i control+C'd my way out. Now let's see what happens when I try again and restart............
This task depends upon

Closed by  Ionut Biru (wonder)
Tuesday, 26 October 2010, 19:41 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#11639 
Comment by Ionut Biru (wonder) - Tuesday, 26 October 2010, 19:26 GMT
congrats, you broke your system because you ran out of space
Comment by jackoneill (jackoneill) - Tuesday, 26 October 2010, 19:33 GMT
I can't wait to hear more...
Comment by trusktr (trusktr) - Tuesday, 26 October 2010, 19:39 GMT
haha, wow, ok. This system update was massive: 350+ packages, 1500+ MB.

I went through about 150 packages before pressing ctrl+c.

I'm guessing i have to make space (somehow), then manually reinstall those 151 packages by typing them all out in one long pacman command (yikes!), right? :(

What's up with this space issue? I have 200 gigs. But i always get a warning message when i log into gnome saying I'm running out of space in the root (/) partition. This has to do with the problem, right? How do i fix this exactly?
Comment by Ionut Biru (wonder) - Tuesday, 26 October 2010, 19:40 GMT
pacman -Scc, set up in pacman.conf a different cache directory, resize root. whatever works
Comment by trusktr (trusktr) - Tuesday, 26 October 2010, 19:41 GMT
You know what would be neat for Arch? Some type of mechanism that adjusts this root partition size automagically, based on the quantity and total size of the packages you use.
Comment by trusktr (trusktr) - Tuesday, 26 October 2010, 19:44 GMT
It's just a guess, but the problem with doing pacman -Scc then redoing pacman -Syu is that it will *think* that the first 150+ packages are already installed, right? So I would have to re-install those 150+ packages manually, right (otherwise they will remain broken)?

It's just a guess and I hope i'm dead wrong, haha.
Comment by Dan McGee (toofishes) - Tuesday, 26 October 2010, 19:47 GMT
No, you need to reinstall everything from the point where the errors started. It should be easy to use your pacman.log to generate a list of packages for you to pass to pacman.

You clearly didn't allocate 200 GB for your root partition, you probably gave way more of that to /home. Try setting up a pacman cache directory (read the manpage) to point at /home/pacman/cache or something for now instead of the default under /var.
Comment by trusktr (trusktr) - Tuesday, 26 October 2010, 20:03 GMT
That's exactly what i was thinking Dan, but I don't actually know where the errors started because the pacman output ran outside the boundaries of the terminal buffer. So i guess i'll just install all of them heheh.

So, if I'm correct, with the standard ~7gb root partition, the main thing users have a problem with is space for the package cache? It'd be neat for pacman to adjust the space of the root partition automatically.


It's kind of hard for me to visualize the "root" partition. What exactly does the root partition consist of? Before my initial encounter with Linux (Arch) this year, partitions were like "indivudual hard drives" in windows, so this new way of seeing partitions (filesystems) is a little confusing.
Comment by Dan McGee (toofishes) - Tuesday, 26 October 2010, 20:09 GMT
Well if you expect pacman to touch your partitions, I can tell you are new to Linux. :) That makes no sense at all. And unfortunately this is not a forum, so please do not ask questions or comment here anymore, especially since this bug report is closed and I'm not going to look at it again.

Loading...