Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21430 - Can't upgrade to man-pages-3.29-1

Attached to Project: Arch Linux
Opened by Geraldo (geraldoav) - Saturday, 23 October 2010, 13:50 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 23 October 2010, 15:05 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Tryed to do a full system upgrade and pacman refuses to install man-pages-3.29-1 because there is a conflict in file /usr/share/man/man3/aio_init.3.gz. This file belongs to libaio 0.3.109-1.

Steps to reproduce:

Try to do a full system upgrade:

[root@geraldoav ~]# pacman -Syu
:: Sincronizando a base de dados de pacotes...
core está atualizado
extra está atualizado
community está atualizado
multilib está atualizado
:: Iniciando atualização do sistema...
resolvendo dependências...
procurando por conflitos internos...

Alvos (1): man-pages-3.29-1

Tamanho total do Download: 0,00 MB
Tamanho Total da Instalação: 14,78 MB

Continuar a instalação? [S/n]
verificando a integridade do pacote...
(1/1) verificando conflitos de arquivo
[################################################################] 100%
erro: falha ao submeter a transação (arquivos conflitantes)
man-pages: /usr/share/man/man3/aio_init.3.gz existe no sistema de arquivos
Ocorreram alguns erros, portanto, nenhum pacote foi atualizado.


[root@geraldoav ~]# pacman -Qo /usr/share/man/man3/aio_init.3.gz
/usr/share/man/man3/aio_init.3.gz pertence a libaio 0.3.109-1
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 23 October 2010, 15:05 GMT
Reason for closing:  Won't fix
Comment by Ionut Biru (wonder) - Saturday, 23 October 2010, 14:09 GMT
i don't know if should be fixed in our man-pages or in libaio package(which is in aur)
Comment by Andreas Radke (AndyRTR) - Saturday, 23 October 2010, 15:05 GMT
libaio is not an official pkg. we ship what man-pages ships upstream. the AUR pkg should be fixed. please file a comment in the AUR pkg section.

Loading...