Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21418 - [amule] fill ram and swap

Attached to Project: Arch Linux
Opened by mattia (nTia89) - Friday, 22 October 2010, 14:54 GMT
Last edited by Giovanni Scafora (giovanni) - Tuesday, 02 November 2010, 06:35 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Giovanni Scafora (giovanni)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

sometime amule fill ram and after the swap just to freeze entire system

is a problem related amule so also amule-adnza (a mod) have it

Additional info:
* amule=2.2.6
* amule-adnza=2010.1
* all other software up to date

Steps to reproduce:

open amule and wait until it fill the ram and swap....
This task depends upon

Closed by  Giovanni Scafora (giovanni)
Tuesday, 02 November 2010, 06:35 GMT
Reason for closing:  Not a bug
Comment by mattia (nTia89) - Saturday, 23 October 2010, 09:27 GMT
some people say me that also bittorrent and other client have the same problem! so i think it isn't an amule problem but we need more evidence ...
Comment by Cihat Ertem (fincan) - Saturday, 23 October 2010, 21:35 GMT
I have the same problem with amule only. Bittorent clients work perfectly.
Comment by Thomas (Halcyon22) - Sunday, 24 October 2010, 15:07 GMT
For a temporary fix you could create a separate user to run amule, and set memory limits in /etc/security/limits.conf for that user. 'man 5 limits.conf' explains it good.
Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 25 October 2010, 18:41 GMT
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Category (Packages: Extra → Upstream Bugs)
  • Field changed: Severity (Critical → Medium)
  • Task assigned to Giovanni Scafora (giovanni)
Please report to upstream. Run with ulimit [options] amule.
Comment by mattia (nTia89) - Monday, 25 October 2010, 19:18 GMT
i post the log output:

http://pastebin.com/ZKkiX80X

Loading...