Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21411 - [chromium] PKGBUILD broken due to python rebuild

Attached to Project: Arch Linux
Opened by Federico Chiacchiaretta (baghera) - Friday, 22 October 2010, 09:18 GMT
Last edited by Pierre Schmitz (Pierre) - Thursday, 28 October 2010, 17:22 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
Dan Griffiths (Ghost1227)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Hi all,
I found that chromium still makedepends on python, but building with python 3 doesn't work. Of course changing makedep to python2 doesn't work, it still looks for /usr/bin/python.

Additional info:
* 6.0.472.62-1

Steps to reproduce:
Try to build chromium with PKGBUILD from abs.
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Thursday, 28 October 2010, 17:22 GMT
Reason for closing:  Fixed
Comment by Ionut Biru (wonder) - Monday, 25 October 2010, 18:36 GMT
logically is not working, the tool that they are using is still using python and have to be adjusted
Comment by solsTiCe (zebul666) - Thursday, 28 October 2010, 09:42 GMT
is this the reason there's still no chromium 7 in extra repo ? chromium 7 is out since october 19.
Comment by Pierre Schmitz (Pierre) - Thursday, 28 October 2010, 10:40 GMT
I am working on this. I think I finally found a working hack. I'll report back once I was able to finish a build.
Comment by Federico Chiacchiaretta (baghera) - Thursday, 28 October 2010, 10:59 GMT
Thanks Pierre :)
Comment by solsTiCe (zebul666) - Thursday, 28 October 2010, 11:32 GMT
here is a PKGBUILD patch that worked for me on i686.
Comment by Federico Chiacchiaretta (baghera) - Thursday, 28 October 2010, 12:44 GMT
I see chromium-7.0.517.43-1 in testing now. I just want to report that chrome stable channel is at version 7.0.517.41 , only google chrome frame has been updated to version .43 .
Comment by Pierre Schmitz (Pierre) - Thursday, 28 October 2010, 13:01 GMT
Yes, noticed that myself...but I don't care that much. :-)
Comment by solsTiCe (zebul666) - Thursday, 28 October 2010, 14:27 GMT
oops ! is it me that introduce that discrepancy ?

I fast read relase annoucement on Google Blog Release and pick up the first version my eyes made contact with
Comment by Ionut Biru (wonder) - Thursday, 28 October 2010, 15:16 GMT
@solsTiCe no. Pierre committed long before you submitted that patch
Comment by Pierre Schmitz (Pierre) - Thursday, 28 October 2010, 17:21 GMT
Well, I just copied&pasted the wrong version. There shouldn't be a noticeable difference between those two versions. It's mostly about unit tests which don't affect the resulting build.

Loading...