Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21308 - [xaos] segfaults when trying to start

Attached to Project: Arch Linux
Opened by Uli (Army) - Monday, 18 October 2010, 20:23 GMT
Last edited by Eric Belanger (Snowman) - Friday, 04 February 2011, 19:47 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture i686
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I just wanted to take a look at the mandelbrot fractal, but xaos only shows me the following output when I try to start it

% xaos
Warning - too long text at line 484
Warning - too long text at line 490
Warning - too long text at line 724
Warning - too long text at line 1026
Warning - too long text at line 1036
Warning - too long text at line 1037
Warning - too long text at line 1040
Warning - too long text at line 1041
Warning - too long text at line 1044
Warning - too long text at line 1047
Warning - too long text at line 1053
Warning - too long text at line 1054
Warning - too long text at line 1058
Warning - too long text at line 1061
[1] 397 segmentation fault (core dumped) xaos

For a very short moment the program window seems to pop up, but then it crashes.

I tried fixing the problem with rebuilding xaos, but that didn't help.

I cannot see if this is already reported upstream, I don't have permission to see the bug reports...

Additional info:
* package version(s)

I use the up to date version from the repos, 3.5-3

* config and/or log files etc.

In case that helps, I could attach the core file created because of the segfault. Or is this a bad idea in general? (I don't know what this file contains exactly)

Steps to reproduce:

Install xaos from [extra] and try to start it
This task depends upon

Closed by  Eric Belanger (Snowman)
Friday, 04 February 2011, 19:47 GMT
Reason for closing:  Works for me
Comment by Eric Belanger (Snowman) - Monday, 18 October 2010, 21:55 GMT
I'm not sure what might be the problem. It works fine here. I don't get any of this "Warning - too long text at line" output.

Try posting on the xaos google group: http://groups.google.com/group/xaos-users
Maybe they'll know what's the problem.
Comment by Uli (Army) - Tuesday, 19 October 2010, 07:39 GMT
Ok thanks, I'll do that.
Comment by Uli (Army) - Thursday, 21 October 2010, 13:29 GMT Comment by nathan (ndowens) - Thursday, 27 January 2011, 08:31 GMT
Just tried running xaos and I don't get the error either.
Comment by Uli (Army) - Friday, 04 February 2011, 18:58 GMT
Ok, xaos works now, don't ask me why... It must depend on the update of a dependency, that's the only idea I have about this. I didn't change anything on my system except of doing the usual updates.

Loading...