Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#2125 - unixodbc to add libmyodbc as package

Attached to Project: Arch Linux
Opened by Armando (aromero3) - Wednesday, 02 February 2005, 06:44 GMT
Task Type Feature Request
Category Packages: Current
Status Closed
Assigned To Judd Vinet (judd)
Architecture not specified
Severity Low
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

MySQL ODBC driver bundled with unixodbc is outdated and I could not get it to work with the database. At this point it seems unixodbc would only be usefull for working directly with flat files or binary files.

Downloaded and compiled ODBC driver from mysql.com.
configure flags that worked for me:
--prefix=/usr --without-x --without-qt --with-mysql-path=/usr --without-samples --disable-thread-safe --disable-gui

Ran like a charm with OpenOffice

So I post this to request that this library be added as a package depended on by unixodbc.

Just something to consider unless it has already been done. Many thanks again unixodbc maintainer.
This task depends upon

Closed by  Judd Vinet (judd)
Wednesday, 02 February 2005, 22:14 GMT
Reason for closing:  Fixed
Comment by Judd Vinet (judd) - Wednesday, 02 February 2005, 18:41 GMT
I have a problem building the MyODBC 3.51.05 package against unixodbc 2.2.10.

catalog.c:510: error: too few arguments to function `int2str'

Looks like mysql's int2str() function has added a fourth parameter. Did you patch the source to get it to build?
Comment by Armando (aromero3) - Wednesday, 02 February 2005, 20:31 GMT
Try getting the latest source, I should have posted what version worked, and that would be 3.51.10 that I worked with, along with the latest pacman packages for unixodbc and mysql. There was no modification to the source code, maybe the version you are compiling with is not new enough to work against the headers for mysql. Also are you using different compile flags than I used?
Comment by Judd Vinet (judd) - Wednesday, 02 February 2005, 22:14 GMT
Whoops, thought that was the latest revision. 3.51.10 builds fine for me. I'll add it today.

Loading...