Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#21228 - [texlive-core] Document compile problem

Attached to Project: Arch Linux
Opened by Alexander (Alex123) - Wednesday, 13 October 2010, 02:13 GMT
Last edited by Allan McRae (Allan) - Saturday, 14 July 2012, 05:47 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Francois Charette (Firmicus)
Rémy Oudompheng (remyoudompheng)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No



Additional info:
* TeX Live 2010.1

end of log file:


Package: nameref 2010/04/30 v2.40 Cross-referencing by name of section

Package: refcount 2008/08/11 v3.1 Data extraction from references (HO)
Package: gettitlestring 2009/12/18 v1.3 Cleanup title references (HO)
LaTeX Info: Redefining \ref on input line 62.
LaTeX Info: Redefining \pageref on input line 62.
LaTeX Info: Redefining \nameref on input line 62.

Package hyperref Warning: Rerun to get /PageLabels entry.

LaTeX Font Info: Font shape `EU1/PTSansCaption(0)/m/n' will be
(Font) scaled to size 9.85144pt on input line 67.
Runaway text?
Scale=MatchLowercase, Mapping=tex-text,Script=Cyrillic,Scale=MatchLow\ETC.
! TeX capacity exceeded, sorry [main memory size=3000000].
<argument> ...ex-text,Scale=MatchLowercase, M\ETC.

l.67 \maketitle{
If you really absolutely need more capacity,
you can ask a wizard to enlarge me.

Here is how much of TeX's memory you used:
17315 strings out of 494535
285750 string characters out of 3161609
3000001 words of memory out of 3000000
20311 multiletter control sequences out of 15000+200000
4146 words of font info for 41 fonts, out of 3000000 for 9000
669 hyphenation exceptions out of 8191
216i,1n,393p,833b,2021s stack positions out of 5000i,500n,10000p,200000b,50000s
No pages of output.


my document:



\defaultfontfeatures{Scale=MatchLowercase, Mapping=tex-text}
\usepackage{xunicode, xltxtra}

\setmainfont{PT Sans}
\setsansfont{PT Sans Caption}
\setmonofont{DejaVu Sans Mono}


\definecolor{SteelBlue}{rgb}{0.274509803922, 0.509803921569, 0.705882352941}
\definecolor{ForestGreen}{rgb}{0.133333333333, 0.545098039216, 0.133333333333}

\definecolor{Grey10}{rgb}{0.1, 0.1, 0.1}
\definecolor{Grey20}{rgb}{0.2, 0.2, 0.2}
\definecolor{Grey30}{rgb}{0.3, 0.3, 0.3}
\definecolor{Grey40}{rgb}{0.4, 0.4, 0.4}
\definecolor{Grey50}{rgb}{0.5, 0.5, 0.5}
\definecolor{Grey60}{rgb}{0.6, 0.6, 0.6}
\definecolor{Grey70}{rgb}{0.7, 0.7, 0.7}
\definecolor{Grey80}{rgb}{0.8, 0.8, 0.8}
\definecolor{Grey90}{rgb}{0.9, 0.9, 0.9}




\date{28 апреля 2010}



Steps to reproduce:
xelatex 1.tex
   1.log (36.7 KiB)
   1.tex (1.5 KiB)
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 14 July 2012, 05:47 GMT
Reason for closing:  No response
Comment by Leonid Isaev (lisaev) - Friday, 15 October 2010, 19:14 GMT
Does it compile for you without the polyglossia/PT* fonts package? I don't have it installed, so had to disable. Otherwise it compiles.
Comment by Alexander (Alex123) - Saturday, 16 October 2010, 10:16 GMT
without polyglossia xetex not work. I send this in Tex Live mailing list:
Comment by Rémy Oudompheng (remyoudompheng) - Saturday, 16 October 2010, 10:45 GMT
1. Please provide minimal examples: that means, if you can remove lines from your tex flie and still get the error, please remove them.

I think there is some incompatibility between fontspec and polyglossia, the following file is a minimal example that triggers an infinite loop in xetex:

\defaultfontfeatures{Scale=MatchLowercase, Mapping=tex-text}
\setmainfont{DejaVu Sans}

It may be related to
Comment by Alexander (Alex123) - Saturday, 16 October 2010, 12:35 GMT
I got the same problem with your minimal example. That means it is a bug?
Comment by Leonid Isaev (lisaev) - Saturday, 16 October 2010, 16:33 GMT
Remy, I had to add \author{}, but otherwise confirm. Also, it seems to be related to the russian default language only.
Comment by Alexander (Alex123) - Tuesday, 16 November 2010, 01:48 GMT
The problem still exists after last update
Comment by JM (fijam) - Tuesday, 03 May 2011, 10:09 GMT
Is the bug still present?
Comment by Alexander (Alex123) - Saturday, 07 May 2011, 05:03 GMT
> Is the bug still present?

Yes, with


\defaultfontfeatures{Scale=MatchLowercase, Mapping=tex-text}
\setmainfont{DejaVu Sans}


Runaway definition?
! TeX capacity exceeded, sorry [main memory size=3000000].
\XKV@ch@cksanitize ...def #2{\the \XKV@tempa@toks
}\@onelevel@sanitize #2\@e...
l.9 \end{document}


But there is no problem with


\setmainfont{DejaVu Sans}
\defaultfontfeatures{Scale=MatchLowercase, Mapping=tex-text}


I think it is XeTeX problem
Comment by Allan McRae (Allan) - Saturday, 16 June 2012, 07:47 GMT