Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21220 - [xf86-video-intel] disable-pageflip.patch disables opengl functionality

Attached to Project: Arch Linux
Opened by Ronald van Haren (pressh) - Tuesday, 12 October 2010, 16:24 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 13 October 2010, 21:17 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The disable-pageflip.patch disables any opengl functionality on my intel gpu. Desktop effects is not working, google earth and glxgears show empty windows.

[ronald@archlinux ~]$ glxinfo | grep renderer
OpenGL renderer string: Mesa DRI Intel(R) Ironlake Mobile GEM 20100330 DEVELOPMENT

Obviously it was fine with xf86-video-intel 2.13.0-1 as the patch wasn't applied there.
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 13 October 2010, 21:17 GMT
Reason for closing:  Fixed
Additional comments about closing:  -3 disables pageflipping patch again. Patching should not be required with a kernel that works correctly.
Comment by Antonis (birdflesh) - Tuesday, 12 October 2010, 17:38 GMT
Confirming the unwanted behaviour on intel x4500. xf86-video-intel 2.13.0-1 was working perfectly.
Comment by Christopher (DIDI2002) - Wednesday, 13 October 2010, 12:42 GMT
In Combination with Compiz, xf86-video-intel 2.13.0-2 renders my Desktop completely useless.
xf86-video-intel 2.13.0-1 works.
Comment by Jan de Groot (JGC) - Wednesday, 13 October 2010, 13:00 GMT
The pageflipping patch cannot be the cause of this problem, as it's nearly the same as the one that was applied to 2.11 and 2.12. With -2 of this driver, three patches have been applied:
- pageflipping patch, does no harm
- 8xx-enable-shadow patch, only does harm on 8xx hardware. It has to be changed to only enable Shadow on 845G, not all 8xx hw
- git patch, does harm to 8xx users, as it assigns the 965 dri driver where it should assign the 915 dri driver on 8xx hardware

The git patch contains a massive change in the device-specific paths. One of these changes breaks DRI for 8xx hardware due to invalid changes, but I assume more mistakes have been made with that change.

I'll release -3 later today with some changes:
- pageflipping is still applied without changes
- 8xx-enable-shadow will only enable shadow on 845G, which is clearly broken without it, 855 seems to work without shadow
- git patch will have http://cgit.freedesktop.org/xorg/driver/xf86-video-intel/commit/?id=4083197a44d1a1a05d33654b3c7d6e96d7472fe7 reverted
Comment by Ronald van Haren (pressh) - Wednesday, 13 October 2010, 13:12 GMT
Are you sure? I locally reverted the git patch you mentioned and it still only works if I don't apply the pageflipping patch.
Comment by Ronald van Haren (pressh) - Wednesday, 13 October 2010, 13:18 GMT
I just removed all patches:
- no patches applied works fine
- only pageflipping patch applied results in no opengl
Comment by Jan de Groot (JGC) - Wednesday, 13 October 2010, 20:10 GMT
thanks for testing. There's not any logic in your findings, but looking in kernel changelogs, there's two commits in linux-2.6 that fix the remaining issues with pageflipping:
- one that fixes the fullscreen freezes
- one that fixes the offset on 965+ hardware with multimonitor setups

I released -3 without pageflipping patch and 8xx-enable-shadow that only enables shadow on 845G, and I updated to the latest git snapshot to fix DRI on 8xx hardware. The kernel will need patching to fix the remaining issues.
Comment by Ronald van Haren (pressh) - Wednesday, 13 October 2010, 20:23 GMT
Just to confirm, -3 fixes opengl functionality for me.

Loading...