Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21218 - [bpython] 0.9.7.1-1 fails to start

Attached to Project: Community Packages
Opened by John Carlyle-Clarke (johncc) - Tuesday, 12 October 2010, 13:54 GMT
Last edited by Thomas Dziedzic (tomd123) - Saturday, 16 October 2010, 13:11 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Thomas Dziedzic (tomd123)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

bpython fails to start at all.


johncc@liberator:~$ pacman -Qi bpython
Name : bpython
Version : 0.9.7.1-1
URL : http://bpython-interpreter.org/
Licences : MIT
Groups : None
Provides : None
Depends On : pygments setuptools
Optional Deps : None
#!/usr/bin/python2
Required By : None
Conflicts With : None
Replaces : None
Installed Size : 564.00 K
Packager : Unknown Packager
Architecture : any
Build Date : Fri 10 Sep 2010 23:00:52 BST
Install Date : Fri 10 Sep 2010 23:01:00 BST
Install Reason : Explicitly installed
Install Script : No
Description : A fancy interface to the Python interpreter

johncc@liberator:~$ bpython
Traceback (most recent call last):
File "/usr/bin/bpython", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
This task depends upon

Closed by  Thomas Dziedzic (tomd123)
Saturday, 16 October 2010, 13:11 GMT
Reason for closing:  Fixed
Comment by Thomas Dziedzic (tomd123) - Tuesday, 12 October 2010, 16:12 GMT
Weird, I thought that error only occurred if setuptools wasn't installed.

Edit: I still haven't been able to reproduce this.
Comment by Ionut Biru (wonder) - Tuesday, 12 October 2010, 16:39 GMT
i'm sorry but the package you listed is not the one from our repos. please reinstall it

pacman -S bpython
Comment by Thomas Dziedzic (tomd123) - Tuesday, 12 October 2010, 16:39 GMT
As pointed out,
Packager : Unknown Packager

This is not an official package in the repos.
Please install it from the repos and try again.

sudo pacman -Syyu
sudo pacman -S bpython
Comment by John Carlyle-Clarke (johncc) - Tuesday, 12 October 2010, 17:55 GMT
Bizarre! Not sure how that happened. Problem persists, however...


johncc@liberator:~$ pacman -Qi bpython
Name : bpython
Version : 0.9.7.1-1
URL : http://bpython-interpreter.org/
Licences : MIT
Groups : None
Provides : None
Depends On : pygments setuptools
Optional Deps : None
Required By : None
Conflicts With : None
Replaces : None
Installed Size : 768.00 K
Packager : Thomas Dziedzic < gostrc at gmail >
Architecture : any
Build Date : Thu 30 Sep 2010 15:38:35 BST
Install Date : Tue 12 Oct 2010 18:52:40 BST
Install Reason : Explicitly installed
Install Script : No
Description : A fancy interface to the Python interpreter

johncc@liberator:~$ bpython
Traceback (most recent call last):
File "/usr/bin/bpython", line 5, in <module>
from pkg_resources import load_entry_point
ImportError: No module named pkg_resources
johncc@liberator:~$ pacman -Qi setuptools
Name : setuptools
Version : 0.6c11-3
URL : http://peak.telecommunity.com/DevCenter/setuptools
Licences : PSF
Groups : None
Provides : None
Depends On : python2
Optional Deps : None
Required By : bpython deluge python-jinja python-pygments
Conflicts With : None
Replaces : None
Installed Size : 1168.00 K
Packager : Allan McRae <allan@archlinux.org>
Architecture : any
Build Date : Wed 18 Aug 2010 04:27:07 BST
Install Date : Tue 05 Oct 2010 08:37:00 BST
Install Reason : Installed as a dependency for another package
Install Script : No
Description : A collection of enhancements to the Python distutils

johncc@liberator:~$
Comment by Eric Belanger (Snowman) - Tuesday, 12 October 2010, 18:01 GMT
it needs to be rebuilt for python 2.7: https://bugs.archlinux.org/task/21204

It looks like John is using the testing repo:

johncc@liberator:~$ pacman -Qi setuptools
Name : setuptools
Version : 0.6c11-3
Comment by John Carlyle-Clarke (johncc) - Tuesday, 12 October 2010, 18:34 GMT
On my system, /usr/bin/python2 has setuptools, but /usr/bin/python (python3) does not. The first line of /usr/bin/bpython is:

#!/usr/bin/python

Changing it to #!/usr/bin/python2 fails because of a whole load of missing libraries, so I'm assuming that bpython is *meant* to run under python 3.x. Does that mean that it's my setuptools package, which depends on python2, which is at fault?

My version 0.6c11-3 is from testing. It depends on python2 and installs to /usr/lib/python2.7/site-packages/
I also tried the version in extra, 0.6c11-2 which depends on "python" and install to /usr/lib/python2.6/site-packages/setuptools (it doesn't work either)

Comment by Thomas Dziedzic (tomd123) - Wednesday, 13 October 2010, 17:10 GMT
I rebuilt bpython for python2 in testing, please try that one.
Comment by Rémy Oudompheng (remyoudompheng) - Saturday, 16 October 2010, 11:07 GMT
bpython seems to run correctly for me, I think we can close this.

Loading...