Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21199 - [pinentry] missing dependencies

Attached to Project: Arch Linux
Opened by Isaac G (IsaacG) - Monday, 11 October 2010, 21:57 GMT
Last edited by Eric Belanger (Snowman) - Sunday, 21 August 2011, 10:44 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The pinentry MAKEPKG file enables a bunch of x11 interfaces which causes it to link to a bunch of libs not pulled in by the dependencies.

(partial output)$ ldd $(which pinentry)
libgtk-x11-2.0.so.0 => not found
libgdk-x11-2.0.so.0 => not found
libpango-1.0.so.0 => not found

Please --disable some features or expand the runtime dependency list.
This task depends upon

Closed by  Eric Belanger (Snowman)
Sunday, 21 August 2011, 10:44 GMT
Reason for closing:  Not a bug
Additional comments about closing:  you need to install the appropriate optdepends
Comment by Isaac G (IsaacG) - Monday, 11 October 2010, 22:25 GMT
Hm. The PKGBUILD deletes pinetry and symlinks it to pinentry-gtk-2... That explains the x11 binary dependency somewhat :)
Comment by Greg (dolby) - Friday, 04 March 2011, 04:13 GMT
The package is designed that way so it can even work in workstations without X (with pinentry-curses).
The X11 interfaces are all optional dependencies:
Optional Deps : gtk: for gtk backend
gtk2: for gtk2 backend
qt3: for qt3 backend
qt: for qt4 backend

That way you can choose which interface to use yourself. Theres plenty available:
pinentry pinentry-curses pinentry-gtk pinentry-gtk-2 pinentry-qt pinentry-qt4

That solution is the most flexible, at least without splitting the package, and gives you the right to choose yourself, instead of making choices for you.

Edit: I dont know the exact reason the pinentry binary is replaced though.

Loading...