Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#21142 - [python-scipy] [python-numpy]

Attached to Project: Community Packages
Opened by Thomas Dziedzic (tomd123) - Friday, 08 October 2010, 06:06 GMT
Last edited by Thomas Dziedzic (tomd123) - Friday, 08 October 2010, 07:33 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Angel Velasquez (angvp)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


python 2.6.5-3
python-scipy 0.8.0-3
python-numpy 1.4.1-1

In a python console type (same for numpy): import scipy

You will get the following error:

Traceback (most recent call last):
File "<input>", line 1, in <module>
File "/usr/lib/python2.6/site-packages/scipy/", line 78, in <module>
from numpy import show_config as show_numpy_config
File "/usr/lib/python2.6/site-packages/numpy/", line 132, in <module>
import add_newdocs
File "/usr/lib/python2.6/site-packages/numpy/", line 9, in <module>
from lib import add_newdoc
File "/usr/lib/python2.6/site-packages/numpy/lib/", line 13, in <module>
from polynomial import *
File "/usr/lib/python2.6/site-packages/numpy/lib/", line 17, in <module>
from numpy.linalg import eigvals, lstsq
File "/usr/lib/python2.6/site-packages/numpy/linalg/", line 47, in <module>
from linalg import *
File "/usr/lib/python2.6/site-packages/numpy/linalg/", line 22, in <module>
from numpy.linalg import lapack_lite
ImportError: /usr/lib/ undefined symbol: blas_zhemv2_x_
This task depends upon

Closed by  Thomas Dziedzic (tomd123)
Friday, 08 October 2010, 07:33 GMT
Reason for closing:  Duplicate
Additional comments about closing:  see last comment
Comment by Austin (doorknob60) - Friday, 08 October 2010, 06:18 GMT
Yeah, numpy (and all programs the depend on it) seems completely broken for me right now, at least with [testing] (maybe it affects people that don't use it too, haven't tried). It worked a couple of days ago.
Comment by Allan McRae (Allan) - Friday, 08 October 2010, 06:42 GMT
See  FS#21135