Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21141 - [archboot] arch_wireless does not include wireless modules

Attached to Project: Arch Linux
Opened by Liu Dongiao (liudongmiao) - Friday, 08 October 2010, 04:15 GMT
Last edited by Tobias Powalowski (tpowa) - Wednesday, 17 October 2012, 13:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
http://projects.archlinux.org/archboot.git/tree/lib/initcpio/install/arch_wireless#n5
misspell wireless as wirless...

Additional info:
* package version(s): archboot through 201008 to 201010
* config and/or log files etc.


Steps to reproduce:

Another suggestion:
In some machine, there is no cursor (software cursor) after booting in archboot.
I think we can put a line to display cursor: (i got it when strace vim)

echo -e "\033[?25h\033[?0c"

/usr/share/archboot/base/etc/profile should be a good place.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Wednesday, 17 October 2012, 13:34 GMT
Reason for closing:  Fixed
Additional comments about closing:  systemd handles console initialization
Comment by Tobias Powalowski (tpowa) - Friday, 08 October 2010, 19:42 GMT
- wireless is now fixed in git, thanks for reporting this.
- about your cursor issue, we don't use this in any file in arch.
Could you point me to some documentation where you got this? Thanks.
Comment by Tobias Powalowski (tpowa) - Monday, 25 October 2010, 20:39 GMT
anything new about the cursor issue? if not I close this soon and please fill a new bugreport about the cursor issue.
Thanks
Comment by Liu Dongiao (liudongmiao) - Tuesday, 26 October 2010, 01:16 GMT
Dear Tobias, sorry, After I got the answer, i forget to paste the attachment.

I have a Dell 11z, when i boot into ramdisk (archboot), i find there is no cursor.
But after i run vim or zhcon (http://aur.archlinux.org/packages.php?ID=), i got the cursor.

then I use strace to find what vim/zhcon print to console..

At the end of strace-vim, something very strange:
write(1, "\33[?25h\33[?0c", 11) = 11
write(1, "\33[48;1H\33[K\33[48;1H", 17) = 17
exit_group(0)

After some test, i got "\33[?25h\33]?0c"...

Here is the documentation from kernel:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=blob;f=Documentation/VGA-softcursor.txt

But i dont know why i need to echo 25h....
from vga-softcursor.txt, we should only need "\33]?0c".

If you cannot reproduce it, then you can just ignore it.
On my fellow's computer, soft-cursor works well without any patch.

My Graphic Card: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller
my fellow's card: a nvidia card. and i forget the exact model.
Comment by Liu Dongiao (liudongmiao) - Tuesday, 26 October 2010, 01:23 GMT
and to tobias, i have some other code to detect the usage of kms module.


if grep -E 'i915|nouveau|radeon|uvesafb' /proc/modules >/dev/null; then
return 0
fi
for fb in i915 nouveau radeon; do
for pci in $(/sbin/modinfo -F alias $fb | sed -e 's/\*/\.&/g'); do
if cat /sys/bus/pci/devices/*/modalias | grep -i $pci >/dev/null; then
msg ":: Switching to $fb kms mode..."
/sbin/modprobe $fb modeset=1
return 0
fi
done
done
Comment by roko (roko) - Saturday, 18 June 2011, 17:52 GMT
hm.. so missspelling is corrected. what about cursor staff?

Loading...