Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21130 - avant-window-navigator applets still points to python3

Attached to Project: Community Packages
Opened by Iven Hsu (ivenvd) - Thursday, 07 October 2010, 14:29 GMT
Last edited by Jakob Gruber (schuay) - Friday, 08 October 2010, 10:58 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Allan McRae (Allan)
Dan Griffiths (Ghost1227)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
In the PKGBUILD, the maintainer changes #!/usr/bin/python to #!/usr/bin/python2, but it doesn't work.
The real location where AWN calls python is in /usr/bin/awn-applet.
The attaching patch should work. I haven't tested it, because AWN fails to build against pyxdg now, which is another problem.
Hope you can fix it soon.

Additional info:
* avant-window-navigator 0.4.0-8
* python2 2.7-2
* pyxdg 0.19-2
This task depends upon

Closed by  Jakob Gruber (schuay)
Friday, 08 October 2010, 10:58 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 0.4.0-9
Comment by Ulf Winkelvos (uwinkelvos) - Thursday, 07 October 2010, 23:08 GMT
patch works fine.

Had to hack the PKGBUILD a bit:
- ./configure --prefix=/usr --sysconfdir=/usr/share
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr --sysconfdir=/usr/share

PYTHON=/usr/bin/python2 --> forces configure to detect python2 (2.7)

edit: removed some nonsense about pyxdg, nevertheless not beeing detected... had old pyxdg installed.

Loading...