Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21108 - [cairo] add respect-fontconfig patch

Attached to Project: Arch Linux
Opened by Paul Gideon Dann (giddie) - Wednesday, 06 October 2010, 15:04 GMT
Last edited by Jan de Groot (JGC) - Monday, 10 January 2011, 09:20 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

The stock Cairo 1.10.0 in [extra] does not apply the respect-fontconfig patch (http://aur.archlinux.org/packages/cairo-ubuntu/cairo-ubuntu/cairo-respect-fontconfig.patch). Without the patch, Cairo incorrectly renders differently to Qt under certain conditions, which results in an inconsistent desktop experience. This patch makes Cairo behave as was intended, and I'm not aware of any down-side to applying it to the stock package. How about it?
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 10 January 2011, 09:20 GMT
Reason for closing:  Won't implement
Additional comments about closing:  I won't implement this for now. Upstream hasn't approved this because the patch needs work before it gets reviewed.
Comment by Olivier (litemotiv) - Saturday, 09 October 2010, 15:45 GMT
+1 for adding this patch, it's the only difference between our stock cairo and the long-needed cairo-lcd. It's not only useful for QT users, but for all users using lcd-filters.
Comment by Andreas Radke (AndyRTR) - Sunday, 19 December 2010, 14:04 GMT
-1 - Arch is intended to ship plain upstream stuff. How does upstream think about it?
Comment by Olivier (litemotiv) - Sunday, 19 December 2010, 14:18 GMT
@Andreas: Upstream is willing to include it, but is taking an *extremely* long time to do so. Bug has been standing on freedesktop since 2007-08-03, last patch was released on 2010-09-21, but upstream complained about unnecessary whitespace and C++ style comments (http://bugs.freedesktop.org/show_bug.cgi?id=11838#c12). All in all, this nitpicking will probably keep the rest of the world from having intended LCD-fontrendering for years to come, if the speed with which upstream tends to react is any indication.

http://bugs.freedesktop.org/show_bug.cgi?id=11838

Loading...