Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21084 - [gtk2] missing icons for the theme

Attached to Project: Arch Linux
Opened by vnoel (kaouete) - Tuesday, 05 October 2010, 12:37 GMT
Last edited by Ionut Biru (wonder) - Tuesday, 19 October 2010, 22:01 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Ionut Biru (wonder)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
Hello,

Since a few days, I am missing the icons for the arrows forward and back of firefox.
When I run it in a console I get the following:
(firefox:16883): Gtk-WARNING **: Error loading theme icon 'gtk-go-back-ltr' for stock: L'icône « gtk-go-back-ltr » n'est pas présente dans le thème
(firefox:16883): Gtk-WARNING **: Error loading theme icon 'gtk-go-forward-ltr' for stock: L'icône « gtk-go-forward-ltr » n'est pas présente dans le thème

Maybe I removed a package containing them, or something like that, but if it is the case, then it should be considered a dependency?

Note: I am using KDE, with last core/extra/multilib for x86_64.
This task depends upon

Closed by  Ionut Biru (wonder)
Tuesday, 19 October 2010, 22:01 GMT
Reason for closing:  Fixed
Additional comments about closing:  gtk2-2.22.0-4
Comment by Ionut Biru (wonder) - Tuesday, 05 October 2010, 14:29 GMT
fallack icon for gtk2 is gnome. gnome-icon-theme 2.32 has those icons
Comment by vnoel (kaouete) - Tuesday, 05 October 2010, 15:16 GMT
Ok, but:
1) should it be a dependency then?
2) they are not the same icons I had before, I don't know at all from where they went, but they were different…
Comment by Tom Tobin (tomxtobin) - Tuesday, 05 October 2010, 17:18 GMT
I had the same issue following a recent package upgrade; installing gnome-icon-theme solved the issue for me.

There's some discussion regarding this bug on the forums:

https://bbs.archlinux.org/viewtopic.php?pid=835978
Comment by stfn (stfn) - Tuesday, 05 October 2010, 17:23 GMT
I can confirm this; pretty much the same thing happened to my firefox too. Unfortunately I don't have further information on what's the problem either.
Comment by Ionut Biru (wonder) - Friday, 08 October 2010, 16:47 GMT Comment by Stephen E. Baker (TheCycoONE) - Sunday, 10 October 2010, 23:34 GMT
A me too.

This issue also prevents nm-applet from running until gnome-icon-theme is installed.
Comment by Ionut Biru (wonder) - Sunday, 10 October 2010, 23:42 GMT
anyone tested the patch from bug report?
Comment by Ray Rashif (schivmeister) - Wednesday, 13 October 2010, 23:42 GMT
It doesn't have to be gnome-icon-theme, it can be any other theme. The only issue is that the gtk settings are not retained across reboots, so gnome-icon-theme works because it is a default fallback.
Comment by Ray Rashif (schivmeister) - Thursday, 14 October 2010, 23:39 GMT
The patch works, but not for nm-applet. Attached is a modified one which fixes that, including _only_ the icon-specific stuff (the third-party/openbsd patch has awk/grep and cups/lpr ammendments - not sure if we want that). And I'm not sure we need ALL of those symlinks either. Well, upstream should know better - we may use this tentatively.
Comment by Pratik Narain (pratik_narain) - Tuesday, 19 October 2010, 20:49 GMT
Applied the old-icon-symlinks.patch file. Network Manager is back to normal behavior.

Loading...