Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#21008 - [gnome-applets] battery applet need libgnome for work

Attached to Project: Arch Linux
Opened by Alois Nespor (anespor) - Thursday, 30 September 2010, 21:09 GMT
Last edited by Jan de Groot (JGC) - Friday, 29 October 2010, 13:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
When i can add battery applet to panel, i can't. Nothing show. Other applets
showed with no problems. When i installed libgnome, added battery applet show and works fine.

Can you add libgnome as optdepend for battery applet? Not as hard dependency.

Additional info:
* package version(s)

gnome-applets 2.32.0-1

* config and/or log files etc.


Steps to reproduce:
add battery applet to gnome-panel without libgnome
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 29 October 2010, 13:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  hal support is removed from gnome-applets.
Comment by Alois Nespor (anespor) - Thursday, 30 September 2010, 21:12 GMT
also not works "mounting local drives applet"
Comment by Jan de Groot (JGC) - Thursday, 30 September 2010, 23:27 GMT
I can't reproduce your problem with these two applets. Both show up fine without libgnome, and both don't link to libgnome in any way. Does installing libgnome bring up additional dependencies?
Comment by Alois Nespor (anespor) - Friday, 01 October 2010, 04:36 GMT
JGC:
OK, thanks. Libgnome is really not dependency.

Libgnome depends on hal. I do not use libgnome or hal in the system. I try to install hal, namely libhal.so only add to the library /usr/ lib.
Log out and log in again. Battery applet shows.

Without the HAL add a battery to the panel, but can not see the icon and does not set.
Strange
Comment by Alois Nespor (anespor) - Friday, 01 October 2010, 04:42 GMT
[root@lenovo pkg]# namcap gnome-applets-2.32.0-1-x86_64.pkg.tar.xz
gnome-applets W: Referenced library 'libbonobo-activation.so.4' is an uninstalled dependency
gnome-applets W: Referenced library 'libpanel-applet-2.so.0' is an uninstalled dependency
gnome-applets W: Referenced library 'libbonobo-2.so.0' is an uninstalled dependency
gnome-applets W: Referenced library 'libhal.so.1' is an uninstalled dependency
gnome-applets W: Dependency 'gucharmap' on your system is a testing release
gnome-applets W: Dependency 'gnome-desktop' on your system is a testing release
gnome-applets W: Dependency 'gdk-pixbuf2' on your system is a testing release
gnome-applets W: Dependency 'gtk2' on your system is a testing release
gnome-applets W: Dependency 'polkit' on your system is a testing release
gnome-applets W: Dependency 'gnome-panel' on your system is a testing release
gnome-applets W: Dependency 'gconf' on your system is a testing release
gnome-applets W: Dependency 'pango' on your system is a testing release
gnome-applets W: Dependency 'libwnck' on your system is a testing release
gnome-applets W: Dependency 'atk' on your system is a testing release
gnome-applets W: Dependency 'libgtop' on your system is a testing release
gnome-applets W: Dependency 'libgweather' on your system is a testing release
gnome-applets W: Dependency 'glib2' on your system is a testing release
gnome-applets W: Dependency included and not needed ('gstreamer0.10-base-plugins')
gnome-applets E: Dependency detected and not included ('hicolor-icon-theme')
gnome-applets W: File (usr/share/xmodmap/xmodmap.la) is a libtool file
Comment by Ionut Biru (wonder) - Friday, 01 October 2010, 08:31 GMT
gnome-power-manager doesn't support hal anymore and nothing in gnome
Comment by Alois Nespor (anespor) - Friday, 01 October 2010, 10:34 GMT
I know, I'm glad that HAL is gone. Maybe forget the battery applet to remove any dependency.

Check that your battery applet shows up when you have installed HAL.
It is possible that the error is only me.

Loading...