Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20974 - [kernel26] Hard crash during boot with 2.6.35.6-1

Attached to Project: Arch Linux
Opened by Alphazo (alphazo) - Tuesday, 28 September 2010, 09:01 GMT
Last edited by Tobias Powalowski (tpowa) - Friday, 26 November 2010, 13:53 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I upgraded my sytem yesterday and the only two new packages were:
- kernel26-2.6.35.6-1
- kernel26-headers-2.6.35.6-1

Upgrade process went fine but when rebooting I get a hard crash after udev:

Stack:
Call Trace:
Code : e8 93.......

udevadm settle - timeout of 180 seconds reached, the event queue contains:
/sys/devices/pci0000:00/0000:00:1f.2/hosts0/target0:/0:0:0:0/block/sda/sda1 (900)
/sys/devices/pci0000:00/0000:00:1f.2/hosts0/target0:/0:0:0:0/block/sda/sda2 (901)
/sys/devices/pci0000:00/0000:00:1f.2/hosts0/target0:/0:0:0:0/block/sda/sda3 (902)
/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.4/1-1.4:1.0 (1274)
.....
[DONE]
:: Bringing up loopback interface
Call Trace:
Code: fe e0 48....

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Friday, 26 November 2010, 13:53 GMT
Reason for closing:  Fixed
Comment by Alphazo (alphazo) - Tuesday, 28 September 2010, 11:50 GMT
Problem disappeared when rolling-back to Kernel 2.6.35.5-1.
Comment by Alphazo (alphazo) - Wednesday, 29 September 2010, 18:00 GMT
Exact same problem with Kernel 2.6.35.7-1. That really worries me. I tried to remove some modules that get loaded during boot (fuse, acpi-cpufreq and vboxdrv) but it doesn't help.

BTW, this is happening on a Lenovo X201 based upon an i5 core.
Comment by jonathan salwan (jonathan salwan) - Wednesday, 29 September 2010, 18:15 GMT
Same problem. But only with my netbook. On two others machines, the kernel works correctly.
Comment by Alphazo (alphazo) - Thursday, 30 September 2010, 06:54 GMT
2.6.36rc6 boots just fine. So to summarize:

- 2.6.35.5: OK
- 2.6.35.6: Fail
- 2.6.35.7: Fail
- 2.6.36rc6: OK
Comment by Mehmet ERİBOL (eribol) - Saturday, 09 October 2010, 14:09 GMT
I installed archlinux and archbang.But they give me same problem. I think its about cpu termal because sensors views high term. But i think its not real value.
Comment by Alphazo (alphazo) - Thursday, 04 November 2010, 13:42 GMT
2.6.35.8: Fail
Comment by MystX (MystX) - Sunday, 07 November 2010, 00:21 GMT
I have this exact same problem. Except I hadn't updated between 2.6.35.4 and 2.6.35.7.
So
- 2.6.35.4: OK
- 2.6.35.7: Fail
- 2.6.35.8: Fail
To back up what Alphazo said.
Comment by Alphazo (alphazo) - Friday, 26 November 2010, 09:18 GMT
I was able to remove kernel26 from my blacklisted packages since 2.6.36 is now the mainstream version. I no longer have any issue.

Loading...