Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20954 - [mkinitcpio] compresses initcpio image with maximum compression (-9); breaks xz on low-mem systems

Attached to Project: Arch Linux
Opened by Borromini (Borromini) - Sunday, 26 September 2010, 17:00 GMT
Last edited by Thomas Bächler (brain0) - Sunday, 27 March 2011, 12:56 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Thomas Bächler (brain0)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Mkinitpcio allows you to pick the compression type through /etc/mkinitpcio.conf but will set the compression level by default to the maximum available (-9).

The offending line:
if ! /sbin/gen_init_cpio ${FILELIST} | ${COMPRESSION} -9 > "${GENIMG}"; then=

On low memory systems (this system has 256 MB RAM) it will make xz complain about not having enough memory available to compress, which causes it to abort (and the whole mkinitcpio process along with it), resulting in empty initcpio images and a de facto unbootable system.

Setting the value from -9 to -6 allows mkinitcpio to build images.

System is fully up to date, not running [testing]. Related BBS topic: https://bbs.archlinux.org/viewtopic.php?id=105547
This task depends upon

Closed by  Thomas Bächler (brain0)
Sunday, 27 March 2011, 12:56 GMT
Reason for closing:  Fixed
Comment by Gerardo Exequiel Pozzi (djgera) - Sunday, 26 September 2010, 17:41 GMT
  • Field changed: Summary (Mkinitpcio compresses initcpio image with maximum compression (-9); breaks xz on low-mem systems → [mkinitpcio] compresses initcpio image with maximum compression (-9); breaks xz on low-mem systems)
  • Field changed: Status (Unconfirmed → Assigned)
  • Field changed: Severity (Critical → Medium)
  • Task assigned to Thomas Bächler (brain0)
Lowering to "medium" since lzma is not the default and there is no "data corruption".
Comment by Thomas Bächler (brain0) - Sunday, 27 March 2011, 12:55 GMT

Loading...