Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20921 - [kde] Debug symbol packages

Attached to Project: Arch Linux
Opened by Simeon (bladud) - Thursday, 23 September 2010, 11:51 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 21 August 2013, 08:48 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 21
Private No

Details

Description:

KDE has, on occasion, been known to crash for some people. It would be nice if there were split debug packages in the arch repos so that useful backtraces could be generated.
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 21 August 2013, 08:48 GMT
Reason for closing:  Upstream
Additional comments about closing:  dbscripts don't handle debug packages yet
Comment by Ionut Biru (wonder) - Thursday, 23 September 2010, 12:13 GMT
makepkg doesn't not support splitting debug.

 FS#10975 
Comment by Pierre Schmitz (Pierre) - Thursday, 23 September 2010, 15:56 GMT
Even if makepkg did support it I doubt it would be worth to package debug symbols for every package.
Comment by Simeon (bladud) - Thursday, 23 September 2010, 22:24 GMT
Presumably you would object to pervasive debug symbols because of all the extra mirror traffic?

I would argue that the base KDE packages in particular would benefit from including debug symbols, because:
a) KDE is complicated, so that the cause of crashes is often not obvious.
b) The crash report thing means that debug packages would actually be useful, and in particular need only be installed after a crash has happened.
c) It is not unknown for KDE to crash.
d) KDE is sufficiently large that recompiling it with symbols is kind of an effort.

Presumably  FS#10975  means that at some point makepkg will support it? Of course this can wait until then.
Comment by Ed Daniel (esdaniel) - Wednesday, 06 October 2010, 21:24 GMT
I'd also like to add my voice to this suggestion and believe it would be great to encourage Arch Linux user community to download debug packages so that they can more easily provide valuable feedback to the KDE community by having access to KDE debug symbols for backtraces.

I concur with Blank, getting every KDE user on Archlinux who wishes to provide useful bug reports to KDE to have to compile their KDE with the debug flag is going to deter a significant proportion of users; thus fewer bug reports thus KDE has less 'data' to help them progress.
Comment by chaofeng (rainofchaos) - Friday, 08 February 2013, 14:45 GMT
  • Field changed: Percent Complete (100% → 0%)
 FS#10975  is already implemented.

Loading...