Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20914 - [cairo] XCB support missing

Attached to Project: Arch Linux
Opened by Adrian C. (anrxc) - Wednesday, 22 September 2010, 11:47 GMT
Last edited by Eric Belanger (Snowman) - Wednesday, 22 September 2010, 21:42 GMT
Task Type Feature Request
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Hello,
cairo packages in [testing] will break some software when it hits [extra], mainly the awesome window manager - which is fairly popular and the problem would result in a lot of broken installations.

Additional info:
* cairo 1.10.0-2
* --enable-xcb missing from the PKGBUILD, or XCB from the packagers system

Excerpt from xsession-errors:
* awesome: symbol lookup error: awesome: undefined symbol: cairo_xcb_surface_create

Building 1.10.0 from abs with XCB support enabled was successful, and awesome recovered.

Thank you.
This task depends upon

Closed by  Eric Belanger (Snowman)
Wednesday, 22 September 2010, 21:42 GMT
Reason for closing:  Not a bug
Comment by Allan McRae (Allan) - Wednesday, 22 September 2010, 12:01 GMT Comment by Adrian C. (anrxc) - Wednesday, 22 September 2010, 12:44 GMT
Thank you.

Loading...