FS#20909 - [texlive-core] : no map cm setup in updmap - very useful fonts (ams) are not found by pdflatex

Attached to Project: Arch Linux
Opened by Etienne Lepercq (guepe) - Tuesday, 21 September 2010, 21:49 GMT
Last edited by Rémy Oudompheng (remyoudompheng) - Sunday, 31 October 2010, 09:47 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Francois Charette (Firmicus)
Rémy Oudompheng (remyoudompheng)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I use texlive and lyx quiet often to write papers, and found out that my pdf were generated using type 3 fonts.
I finally found that the cm map file is not setup in the config file !

Additional info:
* package version(s)
2009.16776-1
* config and/or log files etc.


Steps to reproduce:
- install texlive
- try to produce a pdf with type 1 font only, with a sig-alternate style for example (http://www.acm.org/sigs/publications/proceedings-templates)
- pdf has several unknown fonts that are type 3

Steps to solve the problem :
- launch updmap --edit and add Map cm.map
- pdflatex your_file.tex
- pdffonts your_file.pdf : everything is type 1 now !
This task depends upon

Closed by  Rémy Oudompheng (remyoudompheng)
Sunday, 31 October 2010, 09:47 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Set bug #21371 for instructions to regenerate updmap.cfg
Comment by Etienne Lepercq (guepe) - Monday, 27 September 2010, 20:16 GMT
I found another map that is missing (used for math symbols) : I added Map symbols.map to get some type 1 math symbols in my pdf.
Comment by Rémy Oudompheng (remyoudompheng) - Tuesday, 28 September 2010, 19:11 GMT
Could you attach a minimal .tex file which reproduces the issue ? I would like to test whether it still affects our TeXlive 2010 packages.
Comment by Etienne Lepercq (guepe) - Tuesday, 28 September 2010, 19:42 GMT
Here it is. You need ams proceedings cls file (http://www.acm.org/sigs/publications/proceedings-templates) but maybe try with a standard ieee article. At least when removing the two added maps I get type 3 fonts in the pdf of this tex file.
   test.tex (0.8 KiB)
Comment by Rémy Oudompheng (remyoudompheng) - Tuesday, 28 September 2010, 20:22 GMT
I cannot reproduce the problem with a pristine installation of texlive-bin 2009.5-5 and texlive-core 2009.16776-1, neither with a pristine installation of texlive 2010 from [testing]. It may have appeared during an upgrade.

% grep cm /var/abs/extra/texlive-core/texlive-core.maps
MixedMap cm.map
MixedMap cmextra.map
MixedMap cmtext-bsr-interpolated.map
Comment by Etienne Lepercq (guepe) - Tuesday, 28 September 2010, 20:26 GMT
Ok, maybe during an upgrade, as it has been several times upgraded since my first installation.

Sorry for bothering, at least this bug may help others to understand type 1 fonts problems…

Loading...