Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20860 - [xorg-server] 1.9 + metacity: broken compositing

Attached to Project: Arch Linux
Opened by Jan Steffens (heftig) - Thursday, 16 September 2010, 02:15 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 18 December 2010, 10:49 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

When using metacity in compositing mode together with xorg-server 1.9, menu windows sometimes break when mapped, leaving behind an always-on-top, shadowed, not-redrawn (keeps the previous framebuffer contents) rectangle. This rectangle stays until either the same window is either mapped and unmapped again, or metacity is restarted.

Very annoying.

xorg-server 1.9.0-1
xf86-video-intel 2.12.0-3
metacity 2.30.1-1
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 18 December 2010, 10:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in xorg-server 1.9.3
Comment by Jan Steffens (heftig) - Saturday, 18 September 2010, 09:13 GMT
Now running kernel 2.6.36-rc4 with drm-intel-next branch, problem seems to have disappeared.
Comment by Jan Steffens (heftig) - Saturday, 18 September 2010, 12:13 GMT
Never mind, still happens.
Comment by Jan Steffens (heftig) - Saturday, 18 September 2010, 15:30 GMT
Probably a duplicate of, or at least related to,  FS#20365 
Note that I'm not using a dual monitor setup. Resolution is 1400x1050.
Comment by Ivan Bulatovic (combuster) - Saturday, 25 September 2010, 18:23 GMT
Yeah, I have this one also. Situation is the same with xf86-video-intel 2.12.901 (current git) and with libdrm from git (had to compile that one for 2.13-rc to compile at all). No changes in kernel 2.6.35.5 and 2.6.36-rc5.

I don't have a dual monitor setup, but I do have LVDS disabled with video=LVDS-1:d kernel parametar and LCT 19" monitor on VGA.
Comment by Balló György (City-busz) - Friday, 01 October 2010, 04:01 GMT
I've also experienced it with xf86-video-nouveau 0.0.16_git20100819-1 driver. With xorg-server 1.8 it worked fine.
Comment by Ivan Bulatovic (combuster) - Friday, 01 October 2010, 21:39 GMT
Ok, I've compiled entire xorg stack from git, it looks better now, but I need more testing to make sure. Only xserver is from 1.9 branch as 1.9.99.1 throws me a segfault. I've reported this to upstream.

https://bugs.freedesktop.org/show_bug.cgi?id=30513
Comment by Ivan Bulatovic (combuster) - Saturday, 02 October 2010, 09:22 GMT
Jan, here is the patch. I hope this gets into 1.9.1 upstream but for now a quick rebuild with this patch should fix this.
Comment by Balló György (City-busz) - Wednesday, 06 October 2010, 00:19 GMT
The patch fixed the problem for me.
Comment by Can Celasun (dcelasun) - Saturday, 27 November 2010, 19:30 GMT
I've tested this with both xf86-video-ati-6.13.2-2 and catalyst-10.11. I can also confirm the patch works. I know Arch doesn't like to mess with upstream code but this patch is really really small and simple, so can you please include it in the official package?
Comment by Ivan Bulatovic (combuster) - Saturday, 27 November 2010, 19:32 GMT
https://aur.archlinux.org/packages.php?ID=41438

It has already been fixed upstream and it will appear when xorg-server 1.9.3 hits the repos.
Comment by Can Celasun (dcelasun) - Saturday, 27 November 2010, 19:35 GMT
Yeah, I just saw the revert [1]. Sorry for posting w/o searching :)

[1] http://cgit.freedesktop.org/xorg/xserver/commit/?id=1a0d9324b3d9fd93e685066e0e5cea0611878c0d
Comment by Ivan Bulatovic (combuster) - Saturday, 27 November 2010, 19:44 GMT

Loading...