Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20830 - [xf86-input-synaptics] loads module twice

Attached to Project: Arch Linux
Opened by Stefan Wilkens (stefanwilkens) - Sunday, 12 September 2010, 19:37 GMT
Last edited by Jan de Groot (JGC) - Monday, 17 January 2011, 22:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
With the installation of xf86-input-synaptics, a file is installed to /etc/X11/xorg.conf.d/10-synaptics. The presence of this file seems to cause a double loading of the synaptics driver, sometime leading to a non-functional touchpad:
https://bbs.archlinux.org/viewtopic.php?id=104769

Additional info:
* package version(s): 1.2.2-2
* config and/or log files etc.

/etc/X11/xorg.conf.d/10-synaptics.conf
Section "InputClass"
Identifier "touchpad catchall"
Driver "synaptics"
MatchIsTouchpad "on"
Option "TapButton1" "1"
Option "TapButton2" "2"
Option "TapButton3" "3"
EndSection

Steps to reproduce:
1. install xf86-input-{evdev,synaptics}
2. start x
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 17 January 2011, 22:09 GMT
Reason for closing:  Works for me
Comment by Stefan Wilkens (stefanwilkens) - Sunday, 12 September 2010, 19:40 GMT
the double loading is visible in Xorg.0.log:
[ 9304.803] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[ 9304.803] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"

full log attached
Comment by Stefan Wilkens (stefanwilkens) - Sunday, 12 September 2010, 19:56 GMT
adding:
MatchDevicePath "/dev/input/event*"

to /etc/X11/xorg.conf.d/10-synaptics.conf seems to solve the double module loading issue.

suggested by anti-destin here:
https://bbs.archlinux.org/viewtopic.php?pid=825156#p825156
Comment by Tom Gundersen (tomegun) - Saturday, 23 October 2010, 01:09 GMT
I think the problem is that the device is reported twice by udev:
[ 6.367] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/event7)
[ 6.503] (II) config/udev: Adding input device AlpsPS/2 ALPS GlidePoint (/dev/input/mouse1)

Both of these match the rule in 10-synaptics.conf, but the second one fails to load on my system. If I restrict the rule as described by Stefan then the second instance is ignored.

A consequence is to reduce the start time of X from to 3.8 to 1.1 seconds.

Is there any reason why a touchpad might want to match on /dev/input/mouse* rather than /dev/input/event*?
Comment by Tom Gundersen (tomegun) - Thursday, 18 November 2010, 04:28 GMT
There is a blog entry about this issue from Peter Hutterer here: <http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html>.
Comment by Nico Schottelius (telmich) - Monday, 17 January 2011, 17:35 GMT
  • Field changed: Percent Complete (100% → 0%)
It seems this bug is there again, this time with four lines in the log:
[root@kr ~]# grep -i inputclass /var/log/Xorg.0.log | grep SynPS
[ 130.198] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[ 130.198] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"
[ 1424.694] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "evdev touchpad catchall"
[ 1424.694] (**) SynPS/2 Synaptics TouchPad: Applying InputClass "touchpad catchall"

Scrolling (right side of the touchbad) does not work anymore.

Comment by Tom Gundersen (tomegun) - Monday, 17 January 2011, 18:31 GMT
@telmich: What's in your /etc/X11/xorg.conf.d/10-evdev.conf?
Two things you could try:
1) (probably the proper fix) rename 10-evdev.conf to 11-evdev.conf
2) comment out the "evdev touchpad catchall" section in 10-evdev.conf
Comment by Jan de Groot (JGC) - Monday, 17 January 2011, 19:05 GMT
Please provide logfiles and configuration files. The default configuration has been changed to fix this bug, and in case you didn't take the changes to your configuration (the files are in backup array), then you're still hit by this bug.
Comment by Nico Schottelius (telmich) - Monday, 17 January 2011, 21:48 GMT
10-evdev.conf:

#
# Catch-all evdev loader for udev-based systems
# We don't simply match on any device since that also adds accelerometers
# and other devices that we don't really want to use. The list below
# matches everything but joysticks.

Section "InputClass"
Identifier "evdev pointer catchall"
MatchIsPointer "on"
MatchDevicePath "/dev/input/event*"
Driver "evdev"
EndSection

Section "InputClass"
Identifier "evdev keyboard catchall"
MatchIsKeyboard "on"
MatchDevicePath "/dev/input/event*"
Driver "evdev"
EndSection

Section "InputClass"
Identifier "evdev touchpad catchall"
MatchIsTouchpad "on"
MatchDevicePath "/dev/input/event*"
Driver "evdev"
EndSection

Section "InputClass"
Identifier "evdev tablet catchall"
MatchIsTablet "on"
MatchDevicePath "/dev/input/event*"
Driver "evdev"
EndSection

Section "InputClass"
Identifier "evdev touchscreen catchall"
MatchIsTouchscreen "on"
MatchDevicePath "/dev/input/event*"
Driver "evdev"
EndSection
[22:46] kr:internal%

After moving it to 11-evdev.conf my mouse jumps around heavily, when I use the touchpad.

The logfile is with rename 11-evdev.conf.
Comment by Nico Schottelius (telmich) - Monday, 17 January 2011, 21:49 GMT
This logfile is from the previous run with 10-evdev.conf, but scrolling does not work with the touchpad in this config.
Comment by Nico Schottelius (telmich) - Monday, 17 January 2011, 21:52 GMT
Commenting out

# Section "InputClass"
# Identifier "evdev touchpad catchall"
# MatchIsTouchpad "on"
# MatchDevicePath "/dev/input/event*"
# Driver "evdev"
# EndSection

makes it behave like the original case with 10-evdev.conf (commented it out in the renamed file now).
Comment by Nico Schottelius (telmich) - Monday, 17 January 2011, 21:52 GMT
And attached logfile for the last case.
Comment by Nico Schottelius (telmich) - Monday, 17 January 2011, 21:58 GMT
Ok, found a solution for my problem, executing

% synclient VertEdgeScroll=1

Though it's weired that this stopped being the default
Comment by Jan de Groot (JGC) - Monday, 17 January 2011, 22:09 GMT
Default options depend on your touchpad capabilities. If you have multi-finger support, then two-finger scrolling will become enabled, just like on Apple hardware with Mac OS X. In those cases the edge scrolling is disabled by default. If you hit the touchpad with two fingers, or if there's dirt on the touchpad, it will behave in a way you don't expect. Besides that, some desktop environments like GNOME will set their own defaults, so you can be surprised sometimes. Your reopen request has nothing to do with the initial bugreport.

Loading...