Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20803 - Archlinux does not support various i686 CPUs anymore

Attached to Project: Arch Linux
Opened by Markus Golser (elmargol) - Friday, 10 September 2010, 17:02 GMT
Last edited by Allan McRae (Allan) - Saturday, 11 September 2010, 04:35 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Not all i686 class CPUs do actually support the NOPL instruction. (Intel did not specifiy this instruction in the documentation for i686)
CPUs affected include Via C3, Via Eden, AMD Geode LX (as used in OLPC), Transmeta Crusoe and Virtual PC.

Affected package: binutils

Related Bugreports:
http://www.sourceware.org/bugzilla/show_bug.cgi?id=6957
https://bugzilla.redhat.com/show_bug.cgi?id=579838

The binutils beta contains a fix for this
http://gcc.gnu.org/ml/gcc/2010-08/msg00194.html
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 11 September 2010, 04:35 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#19733 
Comment by Ionut Biru (wonder) - Friday, 10 September 2010, 17:12 GMT
this sounds like a duplicate of  FS#19733 
Comment by Markus Golser (elmargol) - Friday, 10 September 2010, 17:13 GMT
Related archlinux bug marked as won't fix https://bugs.archlinux.org/task/19733

Loading...