Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20748 - [zsh] is dev branch

Attached to Project: Arch Linux
Opened by Caleb Cushing (xenoterracide) - Sunday, 05 September 2010, 15:53 GMT
Last edited by Pierre Schmitz (Pierre) - Wednesday, 06 October 2010, 17:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I'm wondering if this is an intentional decision. I didn't know it before but 4.3.x is the development branch of zsh for the coming stable 4.4. I think my shell is one of the places I don't want dev branch software (even though this seems quite stable). At this point going to 4.2 would seem silly, but perhaps not going to 4.5 when it's released would be prudent.
This task depends upon

Closed by  Pierre Schmitz (Pierre)
Wednesday, 06 October 2010, 17:27 GMT
Reason for closing:  Not a bug
Comment by Pierre Schmitz (Pierre) - Tuesday, 07 September 2010, 04:49 GMT
I don't see your point. This is the only version that is advertised upstream and even Debian oldstable is already using 4.3. Some projects always call their most recent version unstable/in-development etc. no matter what. Do you have any actual problem with 4.3?
Comment by Caleb Cushing (xenoterracide) - Wednesday, 08 September 2010, 04:58 GMT
No actual problems, I just found out that Zsh uses odd releases to denote development versions. I admit they don't do a good job of advertising it, and don't update stable much (since '08) or really why 4.3 isn't ready for primetime yet.

Loading...