Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20733 - [ruby] 1.9.2 installs /usr/lib/ruby/1.9.1/ ?

Attached to Project: Arch Linux
Opened by Philipp √úberbacher (hollunder) - Friday, 03 September 2010, 12:55 GMT
Last edited by Andrea Scarpino (BaSh) - Thursday, 09 December 2010, 13:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Ionut Biru (wonder)
Dan Griffiths (Ghost1227)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Hi.
Since the upgrade to 1.9.2 my mail client, sup, from AUR, doesn't start anymore. The Error messages look kinda weird:
/usr/lib/ruby/1.9.1/rubygems.rb:762:in `report_activate_error': Could not find RubyGem ncurses (>= 0) (Gem::LoadError)

Note the 1.9.1 in the path.
I haven't found a way to fix it. Needless to say that whatever this is about, it's a major breakage for me. I need two different dependencies all of a sudden, but the sup package didn't change, I suspect the ruby package is broken in some way.

Additional info:
* package version(s)
1.9.2_p0-2 and 1.9.2_p0-3

sup package: http://aur.archlinux.org/packages.php?ID=26439&O=&L=&C=&K=&SB=&SO=&PP=&do_Orphans=&SeB=

Forum thread that was no help: https://bbs.archlinux.org/viewtopic.php?id=104193

This task depends upon

Closed by  Andrea Scarpino (BaSh)
Thursday, 09 December 2010, 13:14 GMT
Reason for closing:  Not a bug
Additional comments about closing:  == FAQ
:The standard library is installed in /usr/local/lib/ruby/1.9.1
This version number is "library compatibility version". Ruby 1.9.2 is
mostly compatible with the 1.9.2, so its library is installed in the
directory.
Comment by Jan Steffens (heftig) - Friday, 03 September 2010, 17:37 GMT
The /1.9.1/ paths are correct. The problem has to be something else.
Comment by Philipp √úberbacher (hollunder) - Friday, 03 September 2010, 18:09 GMT
There's talk on the mailinglist in the meanwhile, but apparently no one has any idea of what's wrong: http://rubyforge.org/pipermail/sup-talk/2010-September/004213.html

Loading...