Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20725 - [slim] error pam conversation

Attached to Project: Arch Linux
Opened by mattia (nTia89) - Thursday, 02 September 2010, 20:40 GMT
Last edited by Gaetan Bisson (vesath) - Monday, 06 September 2010, 10:01 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

slim return pam_authenticate error

Additional info:

* slim (latest with default configuration)


Steps to reproduce:

$ slim -p /usr/share/slim/themes/parallel-dimensions/
slim: pam_authenticate(): Conversation error
$
This task depends upon

Closed by  Gaetan Bisson (vesath)
Monday, 06 September 2010, 10:01 GMT
Reason for closing:  Not a bug
Comment by Gaetan Bisson (vesath) - Friday, 03 September 2010, 08:23 GMT
It works fine for me.

Do other themes work for you? Do other login managers work? Can you reproduce this on several computers? Is there anything special pam/slim-related about your setup?
Comment by mattia (nTia89) - Friday, 03 September 2010, 09:52 GMT
yes, i've tried on another archlinux installation. fresh linux installation. openbox started through slim.
if i try to run the command in the xterm i get same error.
Comment by Gaetan Bisson (vesath) - Friday, 03 September 2010, 10:53 GMT
I can't reproduce this so I unfortunately won't be able to investigate myself.
Could you have a look at your /etc/{auth,slim}.log and see if there's any helpful error message?
Comment by mattia (nTia89) - Sunday, 05 September 2010, 08:27 GMT
after i run "slim -p /usr/share/slim/themes/xxx" by gnome-terminal

auth.log:

Sep 5 10:25:20 localhost slim: pam_unix(slim:auth): authentication failure; logname= uid=1000 euid=1000 tty=:0.0 ruser=root rhost=localhost user=mattia
Sep 5 10:25:25 localhost slim: pam_unix(slim:auth): conversation failed
Sep 5 10:25:25 localhost slim: pam_unix(slim:auth): auth could not identify password for [exit]

slim.log:

doesn't exist
Comment by Gaetan Bisson (vesath) - Sunday, 05 September 2010, 10:08 GMT
Well, you're not supposed to "log in" in "slim -p", which is only for theme-preview purposes: since it is not running as root, it can't log anybody in.

Loading...