Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#20716 - [graphicsmagick] Recent GM breaks Octave

Attached to Project: Arch Linux
Opened by Matěj Týč (bubla) - Thursday, 02 September 2010, 08:26 GMT
Last edited by Ronald van Haren (pressh) - Wednesday, 15 December 2010, 21:24 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No


The graphicsmagick-1.3.7-3 breaks image reading in Octave.
The graphicsmagick-1.3.7-2 is OK, though.

I get this error when trying to load a PNG:

error: imread: invalid image file: Magick++ exception: Magick: No decode delegate for this image format () reported by magick/constitute.c:8257 (ReadImage)
error: called from:
error: /usr/share/octave/3.2.4/m/image/imread.m at line 74, column 7

When I downgrade the package, everything is OK.

Additional info:
* package version(s)
This task depends upon

Closed by  Ronald van Haren (pressh)
Wednesday, 15 December 2010, 21:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  upgraded graphicsmagick and octave, re-open if it still doesn't work
Comment by Rodrigo Fernandes (cyber_fusion) - Sunday, 17 October 2010, 21:51 GMT
I can confirm this issue.
Since 1.3.7-2 is no longer available (1.3.7-3 is in extra) i tried looking at the PKGBUILD svn diff ( it seems the only difference is the perl bindings.

I tried looking into it by building rel 2. However I am unable to build any of the releases from source. Both give the following error.

magick/xwindow.c: In function ‘MagickXMakeImage’:
magick/xwindow.c:5738:46: error: ‘ShapeBounding’ undeclared (first use in this function)
magick/xwindow.c:5738:46: note: each undeclared identifier is reported only once for each function it appears in
magick/xwindow.c:5738:67: error: ‘ShapeSet’ undeclared (first use in this function)
make[1]: *** [magick/magick_libGraphicsMagick_la-xwindow.lo] Error 1

Google is not very helpful (or I'm doing it wrong). is sugested but none of the packages refered there are the problem
Comment by Rodrigo Fernandes (cyber_fusion) - Sunday, 17 October 2010, 22:23 GMT
Just build both versions (had to add --with-x=no to configure line in PKGBUILD) I will look into it tomorrow if I have time.
Comment by Ayr0 (ayr0) - Wednesday, 24 November 2010, 19:50 GMT
I can also confirm this.

I solved it by simply rebuilding octave from abs and reinstalling (I also changed the compiler flags from "-O" to "-O2"). Worked nicely.