Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20678 - [git] Missing dependency perl-term-readkey

Attached to Project: Arch Linux
Opened by Florian Richter (flori) - Monday, 30 August 2010, 17:05 GMT
Last edited by Eric Belanger (Snowman) - Tuesday, 31 August 2010, 02:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
git svn dcommit terminates with output:
Can't locate Term/ReadKey.pm in @INC (@INC contains: /usr/share/perl5/site_perl /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/core_perl /usr/share/perl5/core_perl /usr/lib/perl5/site_perl/5.10.1 /usr/share/perl5/site_perl/5.10.1 /usr/lib/perl5/current /usr/lib/perl5/site_perl/current .) at /usr/lib/git-core/git-svn line 4015.
Installing perl-term-readkey fixes the problem

Additional info:
* git 1.7.2.2-1

Steps to reproduce:
clone svn-repro with git
make lokal git commit
run git svn dcommit
This task depends upon

Closed by  Eric Belanger (Snowman)
Tuesday, 31 August 2010, 02:08 GMT
Reason for closing:  Not a bug
Additional comments about closing:  it's an optdepends
Comment by Gerardo Exequiel Pozzi (djgera) - Monday, 30 August 2010, 17:21 GMT
Because is an optional dependency.

optdepends=('tk: gitk and git gui'
'perl-libwww: git svn'
'perl-term-readkey: git svn'
'perl-net-smtp-ssl: git send-email TLS support'
'subversion: git svn'
'cvsps: git cvsimport')

Loading...