AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#20673 - please disallow upload invalid format release version package

Attached to Project: AUR web interface
Opened by Daniel YC Lin (dlin) - Monday, 30 August 2010, 07:15 GMT
Last edited by Lukas Fleischer (lfleischer) - Thursday, 20 January 2011, 17:30 GMT
Task Type Bug Report
Category Backend
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 1.6.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I've upload a grub4dos PKGBUILD.

I used following method to generate pkgver
_pkgver=0.4.5b
_pkgdate=2010-08-12
pkgver=${_pkgver}_${_pkgdate//-/} # this method will failed on aur webpage

I found everything is OK, but the web display the wrong version number as:
0.4.5b_2010-08-12//-/}-1

I suggest to added a blocker to stop user upload invalid version number package.
That include '/', '}' char. Or more, it use a regular expression to check if it match the <version>-<release> format.
This task depends upon

Closed by  Lukas Fleischer (lfleischer)
Thursday, 20 January 2011, 17:30 GMT
Reason for closing:  Duplicate
Additional comments about closing:  Dupe of  FS#15043 . Also, this is probably never gonna be implemented unless we decide to write a full bash parser.
Comment by Daniel YC Lin (dlin) - Tuesday, 11 January 2011, 03:22 GMT
I found in source=(file lists).
The variable used there can not use bash's variable functions.
The pkgver has such limitation.
I suggest add a check on upload php web page to prevent such problem.
Comment by Daniel YC Lin (dlin) - Friday, 21 January 2011, 01:46 GMT
OK, if it can not just check invalid char exist there.
This issue should be close.

Loading...