Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#20660 - [miro] torrent stops after 20-30 seconds

Attached to Project: Arch Linux
Opened by Franco (nimless) - Sunday, 29 August 2010, 13:19 GMT
Last edited by Ronald van Haren (pressh) - Friday, 04 March 2011, 13:37 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ronald van Haren (pressh)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



This happens ONLY on Archlinux so it's not related to Miro or libtorrent-rasterbar.

In Miro ( git or stable doesn't matter) if you add a torrent it stops the download after 20-30 seconds .

This does NOT happen with libtorrent-rasterbar-0.14.x, and happens only on Archlinux. I've tested Fedora and Ubuntu and it works fine with libtorrent-rasterbar-0.15.x

Anyway here is the related bug opened by myself on Miro and the discussion on libtorrent mailing list :

Steps to reproduce:

launch Miro

add a torrent file

wait a bit

torrent stops and hang there
This task depends upon

Closed by  Ronald van Haren (pressh)
Friday, 04 March 2011, 13:37 GMT
Reason for closing:  Fixed
Comment by Ionut Biru (wonder) - Sunday, 29 August 2010, 13:32 GMT
just try other torrent clients that are using libtorrent-rasterbar to see if is really a proper with it.

the only thing that can be different from other distributions is boost and kernel. maybe the network module can handle so many connections and hangs. is just a guess
Comment by Ionut Biru (wonder) - Sunday, 29 August 2010, 13:37 GMT
i'll compile some testing packages against boost 1.42
Comment by Franco (nimless) - Sunday, 29 August 2010, 14:09 GMT
Deluge works ok with libtorrent-rasterbar-0.15.x

By network module you mean the driver of my network card?

Because I've tested Ubuntu on a virtual machine as a guest on this Archlinux machine as host and I had no problems with it.
Comment by Franco (nimless) - Tuesday, 28 September 2010, 15:10 GMT
Any update?
Comment by Ronald van Haren (pressh) - Tuesday, 02 November 2010, 21:03 GMT
status with latest miro?
Comment by Franco (nimless) - Wednesday, 03 November 2010, 12:54 GMT
Same stuff
Comment by Greg (dolby) - Friday, 04 March 2011, 02:52 GMT
The bug has been fixed for 3.5.1 which is now the miro version in the Arch repositories. Is this fixed?
Comment by Franco (nimless) - Friday, 04 March 2011, 13:12 GMT
It is fixed with the latest version of libtorrent-rasterbar