Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20612 - [mkinitcpio] Unable to determine major/minor number of root device

Attached to Project: Arch Linux
Opened by John (graysky) - Thursday, 26 August 2010, 04:59 GMT
Last edited by Dan McGee (toofishes) - Thursday, 26 August 2010, 05:54 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Thomas B├Ąchler (brain0)
Architecture All
Severity Critical
Priority Normal
Reported Version 3.4.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Summary and Info: I'm installing Arch i686 on a rather old PC. Athlon 3000+ on an Asus A7N8X-E motherboard with 512 meg of RAM, 160 G SATA HD, etc. I have successfully installed Arch i686 on similar machines of this vintage just fine.

Installation is uneventful and a reboot will get me into grub just fine, but hangs up with an error message I haven't seen before:

:: Loading Initramfs
:: Starting udevd...
done.
Waiting 10 seconds for device /dev/sda1 ...
ERROR: Unable to determine major/minor number of root device '/dev/sda1'.

Then I get dropped to a recovery shell. I search the forums and found a similar thread where the solution has been to regenerate the initramfs images which I have tried several times over with different HOOKS and MODULES. Same problem.

Relevant line in /boot/grub/menu.lst
# (0) Arch Linux
title Arch Linux
root (hd0,2)
kernel /vmlinuz26 root=/dev/sda1 ro quiet
initrd /kernel26.img

I have also tried alternative methods for defining the grub menu items including UUID, /dev/sdax, and root=0803 (taken from this old kernel trap post: http://kerneltrap.org/node/1955 scroll down to the post by asavva). Also tried adding the "rootfstype=ext4" kernel flag.

Here is the /etc/fstab
devpts /dev/pts devpts defaults 0 0
shm /dev/shm tmpfs nodev,nosuid 0 0

/dev/sda1 / ext4 defaults 0 1
/dev/sda2 swap swap defaults 0 0
/dev/sda3 /boot ext3 defaults 0 1
/dev/sda4 /home ext4 defaults 0 1

Here is the /etc/mkinitcpio.conf
MODULES=""
BINARIES=""
FILES=""
HOOKS="autodetect udev base scsi sata pata filesystems"

Note that I have tried both with and without autodetect and as well adding various modules to the array including: MODULES="sata_sil ata_generic libata pata_amd" both with and without autodetect.

I have also tried using the quick-init (http://aur.archlinux.org/packages.php?ID=25563) package from the AUR in which the disk nodes are defined by the user in an init file but that too gave the same result.

Steps to Reproduce: Install and configure Arch i686 from netinstall-2010.05 or from the Ubuntu 10 live CD via a chroot and attempt to boot it.
This task depends upon

Closed by  Dan McGee (toofishes)
Thursday, 26 August 2010, 05:54 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#20614 
Comment by John (graysky) - Thursday, 26 August 2010, 05:02 GMT
I don't know why this bug report is attached to project pacman - it should be attached to Arch Linux [core] - potentially mkinitcpio/requesting closure.
Comment by John (graysky) - Thursday, 26 August 2010, 05:41 GMT
I opened a new bug report - please close this one: http://bugs.archlinux.org/task/20614
Comment by Dan McGee (toofishes) - Thursday, 26 August 2010, 05:54 GMT
Damn it all. Please just wait next time.

Loading...