Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20604 - [dbus-core] add threadsafe patch for dolphin instability

Attached to Project: Arch Linux
Opened by Ronald van Haren (pressh) - Wednesday, 25 August 2010, 15:17 GMT
Last edited by Jan de Groot (JGC) - Monday, 06 September 2010, 17:54 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

Some unlucky few hit an old dbus bug in kde (mainly dolphin but I believe some other parts are also affected (nepomuk)). The patch (see [2]) is applied upstream, but only to the 1.3 unstable series as it changes some behavior in dbus. KDE bug report is available at [1], an Arch user confirmed the patch to fix the issue at [3].
I can't reproduce this bug myself so I can't do much testing an such. Can we apply the patch to dbus-core, or will this have worse effects on other stuff?

[1] https://bugs.kde.org/show_bug.cgi?id=208921
[2] http://lists.freedesktop.org/archives/dbus/2008-January/009100.html
[3] https://bbs.archlinux.org/viewtopic.php?id=103549
This task depends upon

Closed by  Jan de Groot (JGC)
Monday, 06 September 2010, 17:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  dbus-core 1.2.24-2 is in core now.
Comment by Jan de Groot (JGC) - Thursday, 26 August 2010, 08:35 GMT
The patch mentioned in the mailinglist has been applied to the dbus 1.3 branch. 1.2 has not been touched. Related upstream bugreport is this:
https://bugs.freedesktop.org/show_bug.cgi?id=17754

I could upload a package to testing with the patch applied, but as the bugreport states, it's possible that applications might break because of these changes.
Comment by Ronald van Haren (pressh) - Thursday, 26 August 2010, 08:47 GMT
That's basically what I was wondering, how bad it would break stuff. I've been running it for the last week or so to see if there were any breakages on my computer (I didn't experience the bug so there was no need in that way). I didn't come across anything that stopped working but that's only on a small subset of all packages of course.

I'd say we give it a try in testing, if the cure appears to be worse than the illness we can always roll back to the version without the patch.
Comment by A.F.G. (TuxLin) - Monday, 30 August 2010, 23:30 GMT
I have compiled dbus-1.3.1 package (Amd-x86_64) and replace directly /usr/bin and /usr/lib only files.

After all my tests, dolphin problems has gone and my system is runing ok.


Comment by Jan de Groot (JGC) - Wednesday, 01 September 2010, 12:58 GMT
Please try dbus-core from testing. Patches have been added to solve this bug. If this problem is fixed by the update and no other problems surface, I'll move the package to core.
Comment by A.F.G. (TuxLin) - Wednesday, 01 September 2010, 15:39 GMT

Please, what problem there are in d-bus version 1.3 ?


Comment by Jan de Groot (JGC) - Wednesday, 01 September 2010, 17:54 GMT
dbus 1.3 is the development branch.

Loading...