Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20603 - [xf86-video-intel] Fonts broken

Attached to Project: Arch Linux
Opened by Angel Velasquez (angvp) - Wednesday, 25 August 2010, 13:46 GMT
Last edited by Laurent Carlier (lordheavy) - Saturday, 22 June 2013, 13:00 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:

I'm having random and weird breakage with this driver, when I use vesa.. fonts are displayed correctly, this is my machine work, I usually use nvidia, so mabe there is a workaround to fix this.

Thanks to wonder for giving me some hints.

Additional info:
* package version(s)

[testing] and [extra] versions happens the same

* config and/or log files etc.


Steps to reproduce:

Don't know how to reproduce it .. just fonts broke randomly, and I don't have a clue about what can be useful in the log.

Anything you need, please ask here.
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Saturday, 22 June 2013, 13:00 GMT
Reason for closing:  No response
Additional comments about closing:  No response so it should be fixed
Comment by Jan de Groot (JGC) - Thursday, 26 August 2010, 06:31 GMT
What hardware is this?
Comment by Angel Velasquez (angvp) - Thursday, 26 August 2010, 12:27 GMT
[«angvp@angvpbox ~»]$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
Comment by Jan de Groot (JGC) - Thursday, 21 October 2010, 12:30 GMT
Status with 2.13.0 from testing?
Comment by Juri (lynucs) - Friday, 10 December 2010, 11:06 GMT
same here on thinkpad x41t (intel graphics). I have the feeling it is also depending on hinting/antialias settings. choosing a bigger font in FF while the problem occures, solves the problem sometimes.
Comment by Jan de Groot (JGC) - Thursday, 17 February 2011, 15:36 GMT
Is this still an issue? Kernel, driver, libdrm, X and friends have been updated in the meanwhile.
Comment by Juri (lynucs) - Saturday, 19 February 2011, 22:07 GMT
for me it's still an issue, yes.

intel-dri 7.10.0.git20110215-1
xf86-video-intel 2.14.0-2
kernel 2.6.36

Intel Corporation Mobile 915GM/GMS/910ML Express Graphics Controller (rev 03)
Comment by Juri (lynucs) - Sunday, 20 February 2011, 11:00 GMT
sorry, refresh error
Comment by JM (fijam) - Monday, 02 May 2011, 18:16 GMT
Does the problem persist with current stack?
Comment by Juri (lynucs) - Monday, 02 May 2011, 22:39 GMT
Yes, the problem still occures. However i still don't know how to reproduce. When the problem appears in a browser, I can just increase the size of the font and that artifacts disappear and will appear just after a while. Then I can again try to increase or decrease the font size to cure the problem temporary.

I'm not even sure, whether it is a problem with only some specific fonts used in css or not.

<strike>IIRC that happens only in browsers (gecko _and_ webkit engines).</strike>

Edit: it happens also in terminals. Just switched to
urxvt*font: xft:Dejavu Sans Mono:size=8:antialias=true:hinting=true
in my .Xdefaults and got artifacts.

Can't remember experiencing this with that setting:
urxvt*font: xft:Envy Code R:size=9:hinting=true:antialias=true

Comment by JM (fijam) - Tuesday, 03 May 2011, 08:51 GMT
I did some digging and it seems that is a variation of the following bug: https://bugs.freedesktop.org/show_bug.cgi?id=28151 . Feel free to chime in with the details provided here, maybe it will motivate the devs to have another look at it.

Please mark this bug as upstream.
Comment by norg (norg) - Wednesday, 08 June 2011, 08:34 GMT
I found a workaround here:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/745608

Using the DebugWait Option fixed the problem. But i think they have to fix it nevertheless.
I'm having this bug with Gentoo and i found this bug here :)
Comment by Juri (lynucs) - Tuesday, 14 June 2011, 11:51 GMT
DebugWait option cured my fonts too.
Comment by Olivier (olive) - Friday, 05 August 2011, 17:03 GMT
I have experienced similar problems. Also problem in the title bar (they do not refresh correctly) with xg86-video-intel 2.15.0.2. I have installed xf86-video-intel-git-20110804-1 from the AUR instead (and its dependency) an there is a clear improvement but I can still see problem sometimes. I wonder what happens with the developement of this driver. I have see these problems appear and disappear and appear again according to the upgrade. Seems that upstream can nlot secure a stable version.
Comment by Allan McRae (Allan) - Saturday, 28 April 2012, 16:09 GMT
Status?
Comment by Olivier (olive) - Monday, 30 April 2012, 07:58 GMT
@Allan McRae (Allan) I had read on a forum (I diddn't remember where) that setting

Option "DebugWait" "on"

in the "Device" Section of /etc/X11/xorg.conf fix the problem of broken fonts. So this is what I did and I have no problem of broken fonts anymore but I have not tested it without the option (As the problem is rather random, we should test it for a long time to see the precise status). I have still problem with opengl: glxgears does not run smooth (it shoulkd syc the refresh rate with the screen: i.E. 60 Hz but that does not work well), the workaround is to puyt the fiollowing in /etc/drirc:

<driconf>
<device screen="0" driver="dri2">
<application name="Default">
<option name="vblank_mode" value="0" />
</application>
</device>
</driconf>
Comment by norg (norg) - Wednesday, 25 July 2012, 07:42 GMT
just fyi:

i installed intel 2.20 with sna on my gentoo machine and changed the accel method also to sna:

Option "AccelMethod" "sna"

and i removed the DebugWait line and i have a huge performance improvement and also got rid of the font bug. Maybe you will test this on archlinux, too.
Comment by Greg (dolby) - Tuesday, 16 October 2012, 05:33 GMT Comment by Ondřej Konečný (andrew9888) - Friday, 16 November 2012, 21:20 GMT
I have similar problem with font corruption on my laptop (see the attached image). I have a nVidia graphics card. It might be related. It started after yesterday update.
Comment by Ionut Biru (wonder) - Friday, 16 November 2012, 21:24 GMT
pretty sure is the pixman, xorg updates
Comment by Gerardo Exequiel Pozzi (djgera) - Wednesday, 24 April 2013, 20:12 GMT
status?

Loading...