Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20523 - [slim] Gnome deskbar shutdown applet disabled

Attached to Project: Arch Linux
Opened by Alphazo (alphazo) - Thursday, 19 August 2010, 19:33 GMT
Last edited by Gaetan Bisson (vesath) - Monday, 15 November 2010, 22:36 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details



When switching my login manager from GDM to SLIM I noticed that on my Gnome desktop the shutdown deskbar-applet is greyed out and that I can no longer click on it. I now have to fire up a terminal to shutdown the machine :(

I don't know if this is related but in order to get automatic access to my Gnome keyring I had to apply the following modifications as described in the Wiki.

Added the following lines to /etc/pam.d/slim
auth optional pam_gnome_keyring.so
session optional pam_gnome_keyring.so auto_start

Replaced login_cmd line in /etc/slim.conf by:
login_cmd exec ck-launch-session dbus-launch /bin/bash -login ~/.xinitrc %session >~/.xsession-errors 2>&1

Furthermore my ~/.xinitrc looks like:
#!/bin/sh
exec ck-launch-session gnome-session
This task depends upon

Closed by  Gaetan Bisson (vesath)
Monday, 15 November 2010, 22:36 GMT
Reason for closing:  Won't fix
Comment by Jan de Groot (JGC) - Thursday, 19 August 2010, 20:42 GMT
AFAIK you will also need the pam module from consolekit in the slim pam.d file. The reason why GNOME won't allow you to shutdown anymore is because slim has no consolekit integration.
Comment by Alphazo (alphazo) - Thursday, 19 August 2010, 20:46 GMT
Thanks for the information. Can you provide me some guidance on the modification I should apply to my /etc/pam.d/slim ?

Thank you
Alphazo
Comment by Alphazo (alphazo) - Thursday, 19 August 2010, 20:57 GMT
Just by curiosity I added pam_ck_connector.so to /etc/pam.d/slim but it didn't bring me the shutdown button back :(

auth optional pam_gnome_keyring.so pam_ck_connector.so
session optional pam_gnome_keyring.so pam_ck_connector.so auto_start
Comment by Ionut Biru (wonder) - Thursday, 19 August 2010, 21:02 GMT
you won't get any consolekit support in slim by hacking into pam
Comment by Alphazo (alphazo) - Thursday, 19 August 2010, 21:08 GMT
That's a pretty heavy limitation that prevents from using Slim with Gnome environments. If confirmed, this should be highlighted in the dedicated Slim page found in the wiki.

Loading...