Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20513 - [glibc] segmentation fault on /etc/nsswitch.conf configured to use samba and samba daemons stopped

Attached to Project: Arch Linux
Opened by Daniele Stanzani (stanzani) - Thursday, 19 August 2010, 07:30 GMT
Last edited by Allan McRae (Allan) - Monday, 11 October 2010, 07:48 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Allan McRae (Allan)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
As a result of bug  FS#20243  analysis I have found a way to reproduce a glibc segmentation fault.
Some guys at the libc-help mailing list told me to report this issue here (and at first glance said that should be bad memory on the machine, I'm running some test but the fact that I can reproduce the bug or not as I will).

Additional info:
* package version(s)
glibc version: 2.12.1-1
* config and/or log files etc.
see attached

Steps to reproduce:
Using the file nsswitch.conf i provided, where there are the 'winbind' and 'wins' keywords, and the samba deamons stopped, applications like passwd and xterm segfault.
Removing the two keywords from the file make everything work fine.

This a gdb backtrace of a passwd crash:
#0 0x00007f83eff66068 in ?? () from /lib/libnss_files.so.2
#1 0x00007f83eff66531 in _nss_files_getpwuid_r ()
from /lib/libnss_files.so.2
#2 0x00007f83f0837ebd in getpwuid_r () from /lib/libc.so.6
#3 0x00007f83f083a26a in ?? () from /lib/libc.so.6
#4 0x00007f83f0839f45 in getlogin () from /lib/libc.so.6
#5 0x0000000000403513 in ?? ()
#6 0x00000000004024bd in ?? ()
#7 0x00007f83f07b7c4d in __libc_start_main () from /lib/libc.so.6
#8 0x00000000004018d9 in ?? ()
#9 0x00007fff744fa328 in ?? ()
#10 0x000000000000001c in ?? ()
#11 0x0000000000000001 in ?? ()
#12 0x00007fff744fa8fe in ?? ()
#13 0x0000000000000000 in ?? ()
This task depends upon

Closed by  Allan McRae (Allan)
Monday, 11 October 2010, 07:48 GMT
Reason for closing:  Fixed
Comment by Daniele Stanzani (stanzani) - Friday, 20 August 2010, 15:19 GMT
I was able to reproduce the segmentation fault also on x86 architecture, same application version
Comment by Allan McRae (Allan) - Thursday, 23 September 2010, 14:19 GMT
Do you happen to be running nscd?
Comment by Daniele Stanzani (stanzani) - Friday, 24 September 2010, 07:12 GMT
I do not have nscd running on my system.

Anyway, I have tested that with nscd running all works fine, with nscd stopped glibc segfaults
Comment by Allan McRae (Allan) - Thursday, 07 October 2010, 02:49 GMT
Try the glibc-2.12.1-2 in [testing]. If that still fails, I can build one with debug symbols left in so we can have a better backtrace.
Comment by Daniele Stanzani (stanzani) - Thursday, 07 October 2010, 07:28 GMT
I have tried the glibc-2.12.1-2 from [testing] and the problem seems solved, all works fine, at least on 64bit.

As soon as I find a little bit of time I'll try on 686 architecture.

Thank you Allan
Comment by Allan McRae (Allan) - Thursday, 07 October 2010, 11:26 GMT
OK. The ncsd thing lead me to a seemingly unrelated patch which looks to have worked!
Comment by Allan McRae (Allan) - Monday, 11 October 2010, 07:48 GMT
I'll assume it is fixed on i686 too. Reopen if necessary.

Loading...