Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20492 - [kernel26] iwlagn broken in 2.6.35?

Attached to Project: Arch Linux
Opened by Andreas Neiser (aneiser) - Tuesday, 17 August 2010, 07:25 GMT
Last edited by Allan McRae (Allan) - Tuesday, 05 July 2011, 07:06 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Wireless does not connect through networkmanager. No network traffic is observed.

Additional info:
* package version(s): up to date core except kernel26, linux-firmware and nvidia from testing
* dmesg output when connecting:
iwlagn 0000:03:00.0: PCI INT A disabled
iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, in-tree:
iwlagn: Copyright(c) 2003-2010 Intel Corporation
iwlagn 0000:03:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
iwlagn 0000:03:00.0: setting latency timer to 64
iwlagn 0000:03:00.0: Detected Intel(R) Centrino(R) Ultimate-N 6300 AGN, REV=0x74
iwlagn 0000:03:00.0: Tunable channels: 13 802.11bg, 24 802.11a channels
iwlagn 0000:03:00.0: irq 48 for MSI/MSI-X
iwlagn 0000:03:00.0: loaded firmware version 9.193.4.1 build 19710
phy1: Selected rate control algorithm 'iwl-agn-rs'
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: direct probe to 00:04:0e:6b:80:e6 (try 1)
wlan0: direct probe to 00:04:0e:6b:80:e6 (try 2)
wlan0: direct probe to 00:04:0e:6b:80:e6 (try 3)
wlan0: direct probe to 00:04:0e:6b:80:e6 timed out
...last lines repeat...

Steps to reproduce: Install kernel26, nvidia, linux-firmware from testing on a T510 (Intel Centrino Ultimate-N 6300).
This task depends upon

Closed by  Allan McRae (Allan)
Tuesday, 05 July 2011, 07:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  Original issue fixed in 2.6.39 according to upstream bug report
Comment by Andreas Neiser (aneiser) - Tuesday, 17 August 2010, 07:29 GMT Comment by Roman Kyrylych (Romashka) - Wednesday, 18 August 2010, 12:32 GMT
"up to date core except kernel26, linux-firmware and nvidia from testing" is wrong package version description.
Are you using kernel26-2.6.35.2-1 and linux-firmware-20100807-1 ?
Did you report it at bugzilla.kernel.org ?
Comment by Andreas Neiser (aneiser) - Wednesday, 18 August 2010, 14:01 GMT
Excuse me, I was using (exactly as you guessed):
kernel26-2.6.35.2-1-x86_64.pkg.tar.xz
linux-firmware-20100807-1-any.pkg.tar.xz
<del>nvidia-utils-256.44-1-x86_64.pkg.tar.xz</del>
nvidia-256.44-2-x86_64.pkg.tar.xz
I reported it upstream: https://bugzilla.kernel.org/show_bug.cgi?id=16619
Comment by Andreas Neiser (aneiser) - Thursday, 19 August 2010, 15:02 GMT
It's a problem when using channels 12 or 13 (so specific to European countries). See here: https://bugzilla.kernel.org/show_bug.cgi?id=16462
Comment by Can Celasun (dcelasun) - Friday, 20 August 2010, 19:38 GMT
Do you think this bug is related? http://bugs.archlinux.org/task/20542
Comment by Andreas Neiser (aneiser) - Saturday, 21 August 2010, 06:34 GMT
@Can: Well, don't know exactly, but it seems they changed a lot in 2.6.35. File a bug report upstream and the intel developers will help you. You can try if your wireless becomes stable when using channel 11 or below, since my problem is highly correlated to which channel I use.
Comment by Can Celasun (dcelasun) - Saturday, 21 August 2010, 08:18 GMT
@Andreas: My AP is using channel 1 (2.412 GHz). Is there a channel that you know to be stable?
Comment by Andreas Neiser (aneiser) - Saturday, 21 August 2010, 09:31 GMT
@Can: For me channel 11 works, but I'm using different hardware. I don't think that your problem is related to mine, so I recommend that you file a new bug upstream and leave a link in the bug report here in this tracker...
Comment by Can Celasun (dcelasun) - Saturday, 21 August 2010, 10:26 GMT
Yeah, seems like a different problem, but a lot of things seem to be broken with 2.6.35. I've already reported it upstream: https://bugzilla.kernel.org/show_bug.cgi?id=16691
Comment by JM (fijam) - Tuesday, 03 May 2011, 10:15 GMT
Original submitter's upstream bug is closed. Bug mentioned by Calesun is filed here: https://bugs.archlinux.org/task/20542 . I suppose this can be closed?

Loading...