Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20474 - Visual Corruption in KDE 4.5

Attached to Project: Arch Linux
Opened by Michael Liptrap (xenobrain) - Saturday, 14 August 2010, 17:35 GMT
Last edited by Ronald van Haren (pressh) - Tuesday, 17 August 2010, 10:44 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Visual Corruption in the form of black "sparkles" in KDE 4.5.

Steps to reproduce:
Install KDE 4.5 with xorg 1.8.1 and nvidia driver. Open an application (GTK or Qt). Black "sparkles" appear in the top left corner of the screen, flickering but not shifting when a window is dragged. There are no "sparkles" on an empty desktop, only when a window is open.

If I type $openbox --replace from the terminal while in KDE 4.5, the problem goes away.
This task depends upon

Closed by  Ronald van Haren (pressh)
Tuesday, 17 August 2010, 10:44 GMT
Reason for closing:  Not a bug
Additional comments about closing:  seems to work now
Comment by Michael Liptrap (xenobrain) - Saturday, 14 August 2010, 17:36 GMT
I forgot to add, it doesn't matter if desktop compositing is enabled or not the sparkles are there regardless.
Comment by Michael Liptrap (xenobrain) - Monday, 16 August 2010, 00:58 GMT
Additional information:
This bug also appears when using the KDEmod packages with [core] and [extra].
This bug does NOT appear in the latest KDE 4.5 Chakra image.
This bug does NOT appear in KDE FOUR Live CD based on openSuSE
This bug does NOT appear in Linux Mint with Kubuntu KDE 4.5 packages

Thus, I do not believe this bug is in upstream.
Comment by Ronald van Haren (pressh) - Monday, 16 August 2010, 19:28 GMT
can you test vesa to see if it is related to the video driver?
Comment by Michael Liptrap (xenobrain) - Monday, 16 August 2010, 21:01 GMT
I reinstalled my system with KDE 4.4.5 in [extra] and have been using that. When I saw your message asking about VESA, I synced with [testing]. No visual corruption now. Odd, since the bug affected both Arch KDE and KDEMod when added to a fresh install with no DE installed yet.

I'll see about doing a from-scratch install again and see what happens.
Comment by Michael Liptrap (xenobrain) - Tuesday, 17 August 2010, 01:12 GMT
Did a fresh install, synced straight from testing. The visual corruption isn't there anymore. The installation process from my previous installs was nearly identical in every way. Seems the problem has been fixed, somewhere. Requesting closure.

Loading...