Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#20469 - [mesa] kwin stops updating when changing settings in system settings menu

Attached to Project: Arch Linux
Opened by Tiago Vieira (tvieira) - Saturday, 14 August 2010, 02:25 GMT
Last edited by Andreas Radke (AndyRTR) - Saturday, 12 February 2011, 23:23 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jan de Groot (JGC)
Ronald van Haren (pressh)
Andreas Radke (AndyRTR)
Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: The kde 4.5 is catching when modifies the styles at systemsettings. Chooses the styles, after applies the style, locking the kde.

KDE 4.5.0-2


Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Saturday, 12 February 2011, 23:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  according to the upstream report the should now have the fix included for some time in our mesa builds.
Comment by Ian (Fetid-Frog) - Saturday, 14 August 2010, 17:27 GMT
It only happens in certain sections of systemsettings - all sections under 'Workspace Appearance and Behaviour', and a few others.

When the 'Apply' button is pressed, it stops rendering anything on screen. Disabling compositing and re-enabling it makes everything work again, until the next time a setting is changed.

It happens at other times too - for example, sometimes when loading pages in Firefox I see the previous page until I switch tabs and back again. KDE 4.4.5 worked without any problems.

I have Intel 945 graphics and am using KDE 4.5 from Testing repo.
Comment by Tiago Vieira (tvieira) - Sunday, 15 August 2010, 15:50 GMT
My video card is Intel GM965, is similar to Intel 945. This must be the problem of locking KDE.
Comment by Ionut Biru (wonder) - Monday, 16 August 2010, 14:56 GMT
isn't this bug a duplicate for F#20479
Comment by Ronald van Haren (pressh) - Monday, 16 August 2010, 19:07 GMT Comment by Ronald van Haren (pressh) - Monday, 27 September 2010, 11:43 GMT
I got my hands on a laptop which was also affected by this so I could do some testing.

Jan, this appears to be a mesa bug: https://bugs.freedesktop.org/show_bug.cgi?id=30220

I applied the mentioned one line patch in that bug ( https://bugs.freedesktop.org/attachment.cgi?id=38759 ) locally and that seems to solve this issue. I didn't experience any side-effects, but I've only been using it for the last half our or so, so I'll keep an eye on possible introduced memory leaks.

Comment by Andreas Radke (AndyRTR) - Sunday, 19 December 2010, 19:08 GMT
how's state now with current packages in extra and also test new mesa and intel driver in testing, is it solved?

Loading...