Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#20439 - [kernel26] crashes during bootup

Attached to Project: Arch Linux
Opened by Amitav (amitavmohanty01) - Wednesday, 11 August 2010, 19:08 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 05 January 2011, 12:32 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


During bootup, my kernel has crashed a few times. The occurances have been random and there is no way of reproducing them. I had no way of getting the crash reports so I jotted down one in the text file attached. On subsequent occassions, I have taken snapshots.

Additional info:
* package version(s)
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 05 January 2011, 12:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  kernel26
Comment by Roman Kyrylych (Romashka) - Wednesday, 18 August 2010, 12:58 GMT
The information about the error is not of much use, because it's only the end of stack trace, and no previous lines are visible.
Please provide the list of your hardware and try if 2.6.35 from testing is better.
In addition - are you sure you don't have a hardware problem (i.e. bad memory)?
Comment by Amitav (amitavmohanty01) - Wednesday, 18 August 2010, 20:41 GMT
uname -a
Linux terminal 2.6.34-ARCH #1 SMP PREEMPT Wed Aug 11 00:23:15 CEST 2010 x86_64 Intel(R) Core(TM)2 CPU T5300 @ 1.73GHz GenuineIntel GNU/Linux

My system is a Compaq Presario v6409. I tried running a memtest; but my system passed it: no memory problems. I would be glad to provide more information. Would rc.conf be of any use?
Comment by Amitav (amitavmohanty01) - Thursday, 19 August 2010, 21:13 GMT
I am trying kernel 2.6.35. No issues yet; but as with the earlier kernel, the issues were random and there is no known procedure for reproducing them.
Comment by Thomas Bächler (brain0) - Thursday, 19 August 2010, 22:04 GMT
Before we proceed any further, can you please install memtest and run a memory test? These tests take many hours, but it might be worth it, broken RAM is a common cause for your kind of problems.
Comment by Amitav (amitavmohanty01) - Friday, 20 August 2010, 21:54 GMT
I have tested my RAM module with the memtest package available on Ubuntu disks. It is fine.
Comment by Amitav (amitavmohanty01) - Tuesday, 16 November 2010, 04:50 GMT
Due to  bug 21659 , I cannot use kernel 2.6.35. I had to revert back to 2.6.34 and again I got a kernel panic during bootup.
Comment by Amitav (amitavmohanty01) - Monday, 29 November 2010, 13:11 GMT
Another crash report much similar to the first one.
   crash.jpg (319.9 KiB)
Comment by Thomas Dziedzic (tomd123) - Tuesday, 04 January 2011, 21:42 GMT
Comment by Amitav (amitavmohanty01) - Tuesday, 04 January 2011, 22:32 GMT
Now, I am using and no such problems.